Torna agli aggiornamenti
New releaseSep 5, 2026

parsedmarc v11.0.1

Un pacchetto Python e CLI per analizzare report DMARC aggregati e forensi

Condividi

parsedmarc

Build
Status Code
Coverage PyPI
Package PyPI - Downloads

Uno screenshot dei grafici di riepilogo DMARC in Kibana

parsedmarc è un modulo Python e un'utilità CLI per l'analisi dei report DMARC. Se utilizzato con Elasticsearch e Kibana (o Splunk), oppure con OpenSearch e Grafana, funziona come alternativa open-source self-hosted ai servizi commerciali di elaborazione dei report DMARC quali Agari Brand Protection, Dmarcian, OnDMARC, ProofPoint Email Fraud Defense e Valimail.

[!NOTE] Domain-based Message Authentication, Reporting, and Conformance (DMARC) è un protocollo di autenticazione email.

Questo progetto è mantenuto da un solo sviluppatore. Se tu o la tua organizzazione traete beneficio da questo progetto, prendi in considerazione l'idea di sponsorizzare il mio lavoro.

Funzionalità

  • Analizza i report DMARC aggregate/rua: lo schema legacy draft e quello 1.0 (RFC 7489) e il nuovo schema RFC 9990 per lo standard DMARC finale (RFC 9989)
  • Analizza i report DMARC di tipo failure/ruf (RFC 6591 e RFC 9991; in precedenza chiamati report forensi)
  • Analizza i report di SMTP TLS Reporting (TLS-RPT, RFC 8460)
  • Può analizzare i report da una casella di posta tramite IMAP, Microsoft Graph o Gmail API
  • Gestisce in modo trasparente i report compressi con gzip o zip
  • Strutture dati coerenti
  • Semplice output in JSON e/o CSV
  • Invio opzionale dei risultati via email
  • Invio opzionale dei risultati a Elasticsearch, OpenSearch, Splunk o PostgreSQL, per l'uso con dashboard predefinite
  • Invio opzionale dei risultati ad Apache Kafka, Amazon S3, Azure Log Analytics (Microsoft Sentinel), un endpoint Graylog (GELF), un server syslog, Grafana Loki o un webhook HTTP

Compatibilità Python

Questo progetto supporta le seguenti versioni di Python, che sono attivamente mantenute o rappresentano le versioni predefinite per RHEL o Debian.

VersioneSupportataMotivo
< 3.6❌End of Life (EOL)
3.6❌Utilizzata in RHEL 8, ma non supportata dalle dipendenze del progetto
3.7❌End of Life (EOL)
3.8❌End of Life (EOL)
3.9❌Utilizzata in Debian 11 e RHEL 9, ma non supportata dalle dipendenze del progetto
3.10✅Attivamente mantenuta
3.11✅Attivamente mantenuta; supportata fino a giugno 2028 (Debian 12)
3.12✅Attivamente mantenuta; supportata fino a maggio 2035 (RHEL 10)
3.13✅Attivamente mantenuta; supportata fino a giugno 2030 (Debian 13)
3.14✅Supportata (richiede imapclient>=3.1.0)

Categorie