版本 4.02 2019年9月25日
Xpdf 软件和文档的 版权归 Glyph & Cog, LLC 所有,1996-2019。
电子邮件:[email protected] 网址:http://www.xpdfreader.com/
PDF 数据结构、操作符和规范 记录在 ISO 32000-2:2017 中。
Xpdf 是一个用于便携式文档格式(PDF) 文件的开源查看器。(这些文件有时也被称为“Acrobat”文件, 得名于 Adobe 的 PDF 软件。)Xpdf 项目还包括一个 PDF 文本提取器、PDF 到 PostScript 转换器,以及各种其他 实用工具。
Xpdf 查看器使用 Qt 跨平台 GUI 工具包。其他 命令行实用工具不需要 Qt。
Xpdf 根据 GNU 通用公共许可证(GPL)第 2 版 或第 3 版授权。这意味着你可以根据以下任一方式 分发 Xpdf 的衍生作品:
Xpdf 源代码包包含两个 GPL 版本的文本: COPYING 对应 GPL v2,COPYING3 对应 GPL v3。
请注意,Xpdf 并非根据 GPL 的“任何后续版本”授权, 因为我不知道那些版本会是什么样子。
如果你以二进制形式再分发未修改的 Xpdf 副本(或任何 Xpdf 工具),你需要包含所有 文档:README、手册页(或帮助文件)、COPYING 和 COPYING3。
如果你想将 Xpdf 源代码整合到另一个程序中 (或创建 Xpdf 的修改版本),并且你要分发该 程序,你有两个选择:根据 GPL(v2 和/或 v3)发布你的程序,或购买商业 Xpdf 源代码许可证。
如果你对商业许可感兴趣,请参阅 Glyph & Cog 网站:
http://www.glyphandcog.com/
Xpdf 使用 Qt 工具包,运行于 Linux、Windows 和 OS X——以及 可能还有其他有 Qt 移植版的系统。
非 GUI 命令行实用工具(pdftops、pdftotext、pdftohtml、 pdfinfo、pdffonts、pdfdetach、pdftoppm、pdftopng 和 pdfimages)运行 于 Linux、Windows 和 OS X——并且应该能在几乎任何 有像样 C++ 编译器的系统上运行。
如果你为网页上未列出的系统编译 Xpdf,请 告诉我。如果你愿意通过 ftp 或在网页上提供你的二进制文件,我很乐意从 Xpdf 网页添加链接。我 决定不托管任何不是我自己编译的二进制文件(出于 磁盘空间和支持方面的原因)。
如果你无法在你的系统上编译 Xpdf,给我发电子邮件, 我会尝试帮忙。
最新版本可从以下地址获取:
提供源代码和几个预编译的可执行文件。
新版本的公告会发布到 comp.text.pdf 并通电子邮件 发送给一群人。如果你想接收新版本的 电子邮件通知,只需告诉我。
要运行 xpdf,只需输入:
xpdf file.pdf
要生成 PostScript 文件,请运行 pdftops:
pdftops file.pdf
要生成纯文本文件,请运行 pdftotext:
pdftotext file.pdf
还有几个额外的实用工具(在其手册页中有完整描述):
pdftohtml -- 将 PDF 文件转换为 HTML pdfinfo -- 转储 PDF 文件的 Info 字典(加上一些其他 有用信息) pdffonts -- 列出 PDF 文件中使用的字体以及每个字体的各种 信息 pdfdetach -- 列出或提取 PDF 文件中的嵌入文件(附件) pdftoppm -- 将 PDF 文件转换为一系列 PPM/PGM/PBM 格式 的位图 pdftopng -- 将 PDF 文件转换为一系列 PNG 图像文件 pdfimages -- 从 PDF 文件中提取图像
命令行选项和许多其他细节在手册页中有描述: xpdf(1) 等。
所有这些工具都会读取一个可选的配置文件:参见 xpdfrc(5) 手册页。
参见单独的 INSTALL 文件。
如果你在 Xpdf 中发现 bug,即它打印错误信息、崩溃或错误地显示文档,而你没有在此处看到该 bug 被列出,请给我发邮件,并附上指向该 PDF 文件的指针(URL、ftp 站点等)。
Xpdf 使用以下库:
感谢:
多人贡献了供 pdftex 项目使用的修改:
Adobe Systems Inc., PostScript Language Reference, 3rd ed. Addison-Wesley, 1999, ISBN 0-201-37922-8. [官方 PostScript 手册。]
Adobe Systems, Inc., The Type 42 Font Format Specification, Adobe Developer Support Technical Specification #5012. 1998. http://partners.adobe.com/asn/developer/pdfs/tn/5012.Type42_Spec.pdf [Type 42 是用于在 PostScript 文件中嵌入 TrueType 字体的格式。]
Adobe Systems, Inc., Adobe CMap and CIDFont Files Specification, Adobe Developer Support Technical Specification #5014. 1995. http://www.adobe.com/supportservice/devrelations/PDFS/TN/5014.CIDFont_Spec.pdf [日语和中文字体支持所需的 CMap 文件格式。]
Adobe Systems, Inc., Adobe-Japan1-4 Character Collection for CID-Keyed Fonts, Adobe Developer Support Technical Note #5078. 2000. http://partners.adobe.com/asn/developer/PDFS/TN/5078.CID_Glyph.pdf [Adobe 日文字符集。]
Adobe Systems, Inc., Adobe-GB1-4 Character Collection for CID-Keyed Fonts, Adobe Developer Support Technical Note #5079. 2000. http://partners.adobe.com/asn/developer/pdfs/tn/5079.Adobe-GB1-4.pdf [Adobe 中文 GB(简体)字符集。]
Adobe Systems, Inc., Adobe-CNS1-3 Character Collection for CID-Keyed Fonts, Adobe Developer Support Technical Note #5080. 2000. http://partners.adobe.com/asn/developer/PDFS/TN/5080.CNS_CharColl.pdf [Adobe 中文 CNS(繁体)字符集。]
Adobe Systems Inc., Supporting the DCT Filters in PostScript Level 2, Adobe Developer Support Technical Note #5116. 1992. http://www.adobe.com/supportservice/devrelations/PDFS/TN/5116.PS2_DCT.PDF [DCTDecode 过滤器参数的说明。]
Adobe Systems Inc., Open Prepress Interface (OPI) Specification - Version 2.0, Adobe Developer Support Technical Note #5660. 2000. http://partners.adobe.com/asn/developer/PDFS/TN/5660.OPI_2.0.pdf
Adobe Systems Inc., CMap 文件。 ftp://ftp.oreilly.com/pub/examples/nutshell/cjkv/adobe/ [用于 16 位 CJK 编码的实际 CMap 文件。]
Adobe Systems Inc.,Unicode 字形列表。 http://partners.adobe.com/asn/developer/type/unicodegn.html http://partners.adobe.com/asn/developer/type/glyphlist.txt http://partners.adobe.com/asn/developer/type/corporateuse.txt http://partners.adobe.com/asn/developer/type/zapfdingbats.txt [字符名称与 Unicode 之间的映射。]
Adobe Systems Inc.,OpenType 规范 v. 1.4。 http://partners.adobe.com/public/developer/opentype/index_spec.html [OpenType 字体格式规范。]
Aldus Corp.,OPI:开放印前接口规范 1.3。1993 年。 http://partners.adobe.com/asn/developer/PDFS/TN/OPI_13.pdf
Anonymous,RC4 源代码。 ftp://ftp.ox.ac.uk/pub/crypto/misc/rc4.tar.gz ftp://idea.sec.dsi.unimi.it/pub/crypt/code/rc4.tar.gz [这是用于加密 PDF 文件的算法。]
T. Boutell 等,"PNG(便携式网络图形)规范,版本 1.0"。RFC 2083。 [PDF 使用 PNG 滤波算法。]
CCITT,"信息技术 - 连续色调静态图像的数字压缩和编码 - 要求和指南",CCITT 建议 T.81。 http://www.w3.org/Graphics/JPEG/ [官方 JPEG 规范。]
A. Chernov,"西里尔字符集的注册"。RFC 1489。 [KOI8-R 西里尔编码的文档。]
Roman Czyborra,"ISO 8859 字母汤"。 http://czyborra.com/charsets/iso8859.html [关于各种 ISO 859 编码的文档。]
L. Peter Deutsch,"ZLIB 压缩数据格式规范版本 3.3"。RFC 1950。 [关于 FlateDecode 流中使用的通用格式的信息。]
L. Peter Deutsch,"DEFLATE 压缩数据格式规范版本 1.3"。RFC 1951。 [FlateDecode 流中使用的压缩算法的定义。]
Morris Dworkin,"分组密码工作模式建议",美国国家标准与技术研究院,NIST 特别出版物 800-38A,2001 年。 [PDF 文件中与 AES 配合使用的密码块链接(CBC)模式。]
联邦信息处理标准出版物 197(FIPS PUBS 197),"高级加密标准(AES)",2001 年 11 月 26 日。 [AES 加密,用于 PDF 1.6。]
Jim Flowers,"X 逻辑字体描述约定",版本 1.5,X 联盟标准,X 版本 11,发行版 6.1。 ftp://ftp.x.org/pub/R6.1/xc/doc/hardcopy/XLFD/xlfd.PS.Z [X 字体描述符的官方规范,包括字体变换矩阵。]
Foley、van Dam、Feiner 和 Hughes,计算机图形学:原理与实践,第 2 版。Addison-Wesley,1990 年,ISBN 0-201-12110-7。 [色彩空间转换函数,Bezier 样条数学。]
Robert L. Hummel,程序员技术参考:数据与传真通信。Ziff-Davis Press,1993 年,ISBN 1-56276-077-7。 [CCITT 第 3 组和第 4 组传真解码。]
ISO/IEC,信息技术 -- 二值图像的有损/无损编码。ISO/IEC 14492,第一版(2001-12-15)。 http://webstore.ansi.org/ [官方 JBIG2 标准。该规范的最终草案可从 http://www.jpeg.org/jbighomepage.html 获取。]
ISO/IEC,信息技术 -- JPEG 2000 图像编码系统 -- 第 1 部分:核心编码系统。ISO/IEC 15444-1,第一版(2000-12-15)。 http://webstore.ansi.org/ [官方 JPEG 2000 标准。该规范的最终委员会草案可从 http://www.jpeg.org/JPEG2000.html 获取,但该草案与已发布规范之间的位流格式有所变更。]
ISO,国际标准 -- 文档管理 - 便携式文档格式 - 第 2 部分:PDF 2.0。ISO 32000-2:2017。 [PDF 版本 2.0 的手册。]
ITU,"用于文档传输的第 3 组传真终端的标准化",ITU-T 建议 T.4,1999 年。 ITU,"第 4 组传真设备的传真编码方案和编码控制功能",ITU-T 建议 T.6,1993 年。 http://www.itu.int/ [官方第 3 组和第 4 组传真标准 - 由 CCITTFaxDecode 流以及 JBIG2Decode 流使用。]
B. Kaliski,"PKCS #5:基于密码的密码学规范,版本 2.0"。RFC 2898。 [定义了 PDF 文件中与 AES 加密配合使用的填充方案。]
Christoph Loeffler, Adriaan Ligtenberg, George S. Moschytz, "Practical Fast 1-D DCT Algorithms with 11 Multiplications". IEEE Intl. Conf. on Acoustics, Speech & Signal Processing, 1989, 988-991. [DCTDecode 滤镜中使用的快速 IDCT 算法。]
Microsoft, TrueType 1.0 Font Files, rev. 1.66. 1995. http://www.microsoft.com/typography/tt/tt.htm [TrueType 字体规范(自然是 MS Word 格式)。]