
parsedmarc v11.0.1
एग्रीगेट और फोरेंसिक DMARC रिपोर्ट्स को पार्स करने के लिए एक Python पैकेज और CLI
parsedmarc
parsedmarc DMARC रिपोर्ट पार्स करने के लिए एक Python मॉड्यूल और CLI उपयोगिता है। जब इसे Elasticsearch और Kibana (या Splunk) के साथ, या OpenSearch और Grafana के साथ उपयोग किया जाता है, तो यह Agari Brand Protection, Dmarcian, OnDMARC, ProofPoint Email Fraud Defense, और Valimail जैसी व्यावसायिक DMARC रिपोर्ट प्रोसेसिंग सेवाओं के लिए एक स्व-होस्टेड ओपन-सोर्स विकल्प के रूप में काम करता है।
[!NOTE] Domain-based Message Authentication, Reporting, and Conformance (DMARC) एक ईमेल प्रमाणीकरण प्रोटोकॉल है।
प्रायोजक
यह परियोजना एक डेवलपर द्वारा अनुरक्षित है। यदि आपको या आपके संगठन को इससे लाभ होता है, तो कृपया मेरे काम को प्रायोजित करने पर विचार करें।
विशेषताएँ
- aggregate/rua DMARC रिपोर्ट पार्स करता है: लेगेसी ड्राफ्ट और 1.0 स्कीमा (RFC 7489) और अंतिम DMARC मानक (RFC 9989) के लिए नया RFC 9990 स्कीमा
- failure/ruf DMARC रिपोर्ट पार्स करता है (RFC 6591 और RFC 9991; पहले इन्हें फॉरेंसिक रिपोर्ट कहा जाता था)
- SMTP TLS Reporting (TLS-RPT, RFC 8460) से रिपोर्ट पार्स करता है
- IMAP, Microsoft Graph, या Gmail API के माध्यम से इनबॉक्स से रिपोर्ट पार्स कर सकता है
- gzip या zip संपीड़ित रिपोर्ट को पारदर्शी रूप से संभालता है
- सुसंगत डेटा संरचनाएँ
- सरल JSON और/या CSV आउटपुट
- वैकल्पिक रूप से परिणाम ईमेल करता है
- वैकल्पिक रूप से परिणाम Elasticsearch, OpenSearch, Splunk, या PostgreSQL को भेजता है, पूर्व-निर्मित डैशबोर्ड के साथ उपयोग के लिए
- वैकल्पिक रूप से परिणाम Apache Kafka, Amazon S3, Azure Log Analytics (Microsoft Sentinel), एक Graylog (GELF) एंडपॉइंट, एक syslog सर्वर, Grafana Loki, या एक HTTP वेबहुक को भेजता है
Python संगतता
यह परियोजना निम्नलिखित Python संस्करणों का समर्थन करती है, जो या तो सक्रिय रूप से अनुरक्षित हैं या RHEL या Debian के लिए डिफ़ॉल्ट संस्करण हैं।
| संस्करण | समर्थित | कारण |
|---|---|---|
| < 3.6 | ❌ | जीवनकाल समाप्त (EOL) |
| 3.6 | ❌ | RHEL 8 में उपयोग किया जाता है, लेकिन परियोजना निर्भरताओं द्वारा समर्थित नहीं |
| 3.7 | ❌ | जीवनकाल समाप्त (EOL) |
| 3.8 | ❌ | जीवनकाल समाप्त (EOL) |
| 3.9 | ❌ | Debian 11 और RHEL 9 में उपयोग किया जाता है, लेकिन परियोजना निर्भरताओं द्वारा समर्थित नहीं |
| 3.10 | ✅ | सक्रिय रूप से अनुरक्षित |
| 3.11 | ✅ | सक्रिय रूप से अनुरक्षित; जून 2028 तक समर्थित (Debian 12) |
| 3.12 | ✅ | सक्रिय रूप से अनुरक्षित; मई 2035 तक समर्थित (RHEL 10) |
| 3.13 | ✅ | सक्रिय रूप से अनुरक्षित; जून 2030 तक समर्थित (Debian 13) |
| 3.14 | ✅ | समर्थित (imapclient>=3.1.0 आवश्यक) |