
New releaseSep 5, 2026
parsedmarc v11.0.1
集約DMARCレポートとフォレンジックDMARCレポートを解析するためのPythonパッケージおよびCLI
parsedmarc
parsedmarc は、DMARC レポートを解析するための Python モジュール兼 CLI ユーティリティです。Elasticsearch と Kibana(または Splunk)、あるいは OpenSearch と Grafana と組み合わせて使用すると、Agari Brand Protection、Dmarcian、OnDMARC、ProofPoint Email Fraud Defense、Valimail といった商用の DMARC レポート処理サービスに対する、セルフホスト型のオープンソース代替として機能します。
[!NOTE] Domain-based Message Authentication, Reporting, and Conformance(DMARC)は、電子メール認証プロトコルです。
スポンサー
このプロジェクトは 1 人の開発者によって維持されています。 あなたやあなたの組織がこのプロジェクトから恩恵を受けている場合は、私の活動へのスポンサーをご検討ください。
機能
- 集約/rua DMARC レポートを解析します:レガシードラフトおよび 1.0 スキーマ(RFC 7489)、ならびに最終的な DMARC 標準(RFC 9989)向けの新しい RFC 9990 スキーマに対応
- 失敗/ruf DMARC レポートを解析します(RFC 6591 および RFC 9991。以前はフォレンジックレポートと呼ばれていました)
- SMTP TLS Reporting(TLS-RPT、RFC 8460)のレポートを解析します
- IMAP、Microsoft Graph、または Gmail API 経由で受信トレイからレポートを解析できます
- gzip または zip で圧縮されたレポートを透過的に処理します
- 一貫したデータ構造
- シンプルな JSON および/または CSV 出力
- オプションで結果をメール送信
- オプションで結果を Elasticsearch、OpenSearch、Splunk、または PostgreSQL に送信し、既製のダッシュボードで利用可能
- オプションで結果を Apache Kafka、Amazon S3、Azure Log Analytics(Microsoft Sentinel)、Graylog(GELF)エンドポイント、syslog サーバー、Grafana Loki、または HTTP Webhook に送信
Python 互換性
このプロジェクトは、現在も活発にメンテナンスされているか、RHEL または Debian のデフォルトバージョンである以下の Python バージョンをサポートしています。
| バージョン | サポート | 理由 |
|---|---|---|
| < 3.6 | ❌ | サポート終了(EOL) |
| 3.6 | ❌ | RHEL 8 で使用されているが、プロジェクトの依存関係でサポートされていない |
| 3.7 | ❌ | サポート終了(EOL) |
| 3.8 | ❌ | サポート終了(EOL) |
| 3.9 | ❌ | Debian 11 および RHEL 9 で使用されているが、プロジェクトの依存関係でサポートされていない |
| 3.10 | ✅ | 活発にメンテナンス中 |
| 3.11 | ✅ | 活発にメンテナンス中。2028 年 6 月までサポート(Debian 12) |
| 3.12 | ✅ | 活発にメンテナンス中。2035 年 5 月までサポート(RHEL 10) |
| 3.13 | ✅ | 活発にメンテナンス中。2030 年 6 月までサポート(Debian 13) |
| 3.14 | ✅ | サポート対象(imapclient>=3.1.0 が必要) |