返回更新列表
新发布Sep 30, 2026

openssl openssl-4.0.3

通用 TLS 和加密库

分享

欢迎来到 OpenSSL 项目

openssl logo

github actions ci badge Nightly OS Zoo ci badge Provider Compatibility Quic Interop Daily checks LFX Health Score

OpenSSL 是一个健壮、商业级、功能齐全的开源工具包, 用于传输层安全(TLS,原称 SSL)、数据报 TLS(DTLS)和 QUIC 协议。

这些协议实现基于一个全强度的通用密码学库, 该库也可以独立使用。此外还包含一个经过验证、 符合 FIPS 标准的密码学模块。

OpenSSL 源自 Eric A. Young 和 Tim J. Hudson 开发的 SSLeay 库。

OpenSSL 项目的官方主页是 www.openssl.org。

目录

概述

OpenSSL 工具包包括:

  • libssl 所有 TLS 协议版本直至 TLSv1.3(RFC 8446)、 DTLS 协议版本直至 DTLSv1.3(RFC 9147)以及 QUIC 版本 1 协议(RFC 9000)的实现。

  • libcrypto 一个全强度的通用密码学库。它构成了 TLS 实现的基础,但也可以独立使用。

  • openssl OpenSSL 命令行工具,是密码学任务、测试和分析的 瑞士军刀。它可用于

    • 创建密钥参数
    • 创建 X.509 证书、CSR 和 CRL
    • 计算消息摘要
    • 加密和解密
    • SSL/TLS/DTLS 以及客户端和服务器测试
    • QUIC 客户端测试
    • 处理 S/MIME 签名或加密邮件
    • 以及更多...

下载

用于生产环境

官方发布的源代码压缩包可从 openssl-library.org/source/ 下载。 OpenSSL 项目不以二进制形式分发该工具包。

然而,对于多种操作系统,都有预编译版本的 OpenSSL 工具包可用。特别是在 Linux 和其他 Unix 操作系统上,通常建议链接到 发行商或供应商提供的预编译共享库。

我们还在 wiki 的 Binaries 页面上维护了一份 为各种操作系统(包括 Windows)生成 OpenSSL 二进制文件的 第三方列表。

用于测试和开发

尽管理论上也可以使用源代码压缩包进行测试和开发, 但拥有包含整个项目历史的 git 仓库本地副本 能让您更深入地了解代码库。

主要的 OpenSSL Git 仓库是私有的。 在 github.com/openssl/openssl 有一个它的公开 GitHub 镜像, 每次提交时都会从前者自动更新。

可以通过从 GitHub 镜像克隆来获取 Git 仓库的本地副本:

git clone https://github.com/openssl/openssl.git

如果您打算为 OpenSSL 做贡献,无论是修复 bug 还是贡献 新功能,您需要 fork GitHub 镜像并克隆您的公开 fork:

git clone https://github.com/yourname/openssl.git

这是必要的,因为如今 OpenSSL 的所有开发都是通过 GitHub pull request 完成的。更多详情,请参见贡献。

构建与安装

获取源代码后,请查看 INSTALL 文件以了解 构建和安装 OpenSSL 的详细说明。对于某些 平台,安装说明会由平台特定的文档补充。

从先前版本升级到 OpenSSL 3.x 的具体说明可在 ossl-guide-migration(7ossl) 手册页中找到。

文档

README 文件

源代码分发的顶层有一些 README.md 文件, 包含关于特定主题的附加信息。

OpenSSL 指南

在 OpenSSL Guide 中有一些关于重要 OpenSSL 主题的 教程和入门页面。

手册页

master 分支和所有当前稳定版本的手册页 可在线获取。

示例

在 demos 子文件夹 中有大量使用各种 OpenSSL 功能的 源代码示例。

Wiki

有一个 GitHub Wiki,目前不太活跃。

许可证

OpenSSL 采用 Apache License 2.0 许可,这意味着 只要您满足其条件,就可以自由地将其用于商业和非商业 目的。

更多详情请参见 LICENSE.txt 文件。

支持

有多种联系方式。正确的渠道取决于 您的需求。更多详情请参见 SUPPORT 文件。

贡献

如果您有兴趣并愿意为 OpenSSL 项目做贡献, 请查看 CONTRIBUTING 文件。

法律事项

许多国家限制密码学的使用或出口。如果您 可能受到此类限制,在尝试开发或分发密码学代码之前, 应寻求法律建议。

版权

Copyright (c) 1998-2026 The OpenSSL Project Authors

Copyright (c) 1995-1998 Eric A. Young, Tim J. Hudson

保留所有权利。

分类