Skip to content
KitploitKITPLOIT
FerramentasExploitsBlog
Log in
Enviar
FerramentasExploitsBlog
Enviar

Ferramentas de Hacking, PenTest e Cibersegurança para o seu Arsenal de Segurança!

Kitploit é um diretório de ferramentas de hacking, cibersegurança e pentesting. Descubra as últimas atualizações de projetos para encontrar vulnerabilidades, analisar sistemas, automatizar testes e fortalecer sua segurança.

FeedsContatoPrivacidade© 2026 Kitploit

Diretório de Ferramentas

Categorias

Ver todas as categorias
Loading categories
Titanis — Biblioteca de protocolos do Windows, incluindo implementações de SMB e RPC, entre outros. | Kitploit
Ferramentas/GitHubGitHub/trustedsec/titanis
Escalada de PrivilégiosExploraçãoMovimento LateralColeta de InformaçõesSegurança de RedeCriptografiaTestes de PenetraçãoUtilitários e FrameworksAutenticaçãoRed Teaming
GitHubtrustedsec/titanis
8238638há 29 diasRevisado pelo Kitploit

Mais Populares

Ver todos →

Descubra as ferramentas mais usadas pela nossa comunidade.

Explore todas as ferramentas

Navegue pela nossa coleção de ferramentas

Ver todas as ferramentas →
Compartilhar

Titanis

Biblioteca de protocolos do Windows, incluindo implementações de SMB e RPC, entre outros.

Ver Repositório

View the User Guide on the documentation site

Introdução

Titanis é uma biblioteca de implementações de protocolos e utilitários de linha de comando, escritos em C#, para interagir com ambientes Windows. Ele usa .NET 8 e é multiplataforma (Windows e Linux). Alguns dos protocolos implementados:

  • SMB2 (MS-SMB2)
    • SMB 2.x e 3.x até 3.1.1
    • Recursos de segurança de mensagens, como assinatura e criptografia
    • Inclui suporte para códigos de controle do sistema de arquivos (MS-FSCC)
    • Links DFS (MS-DFSC)
  • MSRPC (MS-RPCE)
    • Mapeador de endpoints
    • DCOM (MS-DCOM)
    • Replicação de diretório (MS-DRSR)
      • Testado com Windows Server 2008 e Windows Server 2025
      • Suporta compressão MS-ZIP e Xpress
      • Suporta replicação de objetos individuais ou partições inteiras
    • EFS (MS-EFSR)
    • LSA (MS-LSAD e MS-LSAT)
    • Registro remoto (MS-RRP)
      • Inclui suporte para semântica de backup
      • Inclui funcionalidade de dump do SAM
    • Gerenciador de contas de segurança (MS-SAMR)
    • Gerenciador de controle de serviços (MS-SCMR)
    • Serviço de servidor (MS-SRVS)
    • WMI (MS-WMI e MS-WMIO)
    • Replicação de diretório (MS-DRSR)
    • EventLog Remoting Protocol Version 6.0 (MS-EVEN6)
    • Task Scheduler Service Remoting Protocol (MS-TSCH)
    • Remote Authorization API Protocol (MS-RAA)
    • Firewall and Advanced Security Protocol (MS-FASP)
  • LDAP (RFC 4511 e partes de MS-ADTS)
  • Segurança
    • NTLM (MS-NLMP)
    • Kerberos (RFC4120 e MS-KILE)
      • Referrals inter-realm
      • PKINIT (MS-PKCA e RFC 4556)
      • S4U (MS-SFU)
        • S4U2self
        • S4U2proxy
      • Perfis de criptografia
        • DES CBC MD5 (RFC3961) (somente AS)
        • RC4-HMAC (RFC4757)
        • AES 128/256 (RFC3962)
        • Suporte para arquivos .kirbi e ccache
        • Suporte para arquivos keytab
      • Alterar / definir senha (RFC3244)
      • FAST / Armoring e identidade composta
    • SP-NEGO (MS-SPNG)
  • Suporte integrado a SOCKS 5 (parâmetro -Socks5) (RFC1928)

Para alterações recentes, consulte o change log

Para uma visão geral dos cenários de autenticação suportados, consulte Authentication - Descreve como controlar a autenticação com parâmetros

O conjunto de ferramentas implementa callbacks e recursos de logging para integrar ao seu ambiente operacional.

Para obter uma lista de ferramentas de linha de comando e tarefas que você pode executar com elas, consulte o Tool Index

Público-alvo

  • Pesquisadores de segurança - Pesquisar como o Windows reage a vários tipos de requisições
  • Pentesters - Executar ações e testar se as mitigações estão habilitadas e funcionando corretamente
  • Administradores de sistemas - Executar tarefas administrativas

Primeiros Passos

Build Instructions

Se você é um usuário, consulte o User Guide para obter uma lista de utilitários de linha de comando e como usá-los.

Se você é um desenvolvedor, consulte o Developer Guide para obter informações sobre como aprimorar a base de código.

Organização do Projeto

  • doc/ - Documentação do projeto
  • src/ - Código-fonte das implementações de protocolos
  • test/ - Testes unitários
  • tools/ - Ferramentas de linha de comando autônomas
  • samples/ - Código de exemplo que demonstra como usar as bibliotecas

Dentro de Titanis.sln, os projetos são agrupados nas seguintes áreas funcionais:

  • Base - Utilitários usados por outros componentes
  • Crypto - Implementação de algoritmos criptográficos
  • Formats - Implementações para leitura e escrita de vários formatos, como ASN.1
  • Protocols - Implementações de protocolos de rede
  • Security - Implementações de protocolos de segurança, como NTLM e Kerberos
  • Test - Testes unitários
  • Tools - Ferramentas de linha de comando autônomas
  • _Build - Arquivos relevantes para o processo de build.

Vários dos projetos contêm um arquivo chamado References.txt que referencia as especificações consultadas durante o desenvolvimento. O código-fonte contém referências a essas especificações, geralmente junto com o número da seção relevante.

Baixar ferramenta