Skip to content
KitploitKITPLOIT
도구익스플로잇블로그
Log in
제출
도구익스플로잇블로그
제출

해킹, 침투 테스트 및 사이버 보안 도구를 당신의 보안 무기고에!

Kitploit은 해킹, 사이버 보안 및 침투 테스트 도구 디렉토리입니다. 최신 프로젝트 업데이트를 발견하여 취약점을 찾고, 시스템을 분석하고, 테스트를 자동화하고, 보안을 강화하세요.

피드문의개인정보© 2026 Kitploit

도구 디렉토리

카테고리

모든 카테고리 보기
Loading categories
Titanis — Windows 프로토콜 라이브러리로, SMB 및 RPC 구현 등을 포함합니다. | Kitploit
도구/GitHubGitHub/trustedsec/titanis
Privilege EscalationExploitationLateral MovementInformation GatheringNetwork SecurityCryptographyPenetration TestingUtilities & FrameworksAuthenticationRed Teaming
GitHubtrustedsec/titanis
823863728일 전Kitploit 검토 완료

인기

모두 보기 →

커뮤니티에서 가장 많이 사용되는 도구를 찾아보세요.

모든 도구 탐색

도구 컬렉션을 둘러보세요

모든 도구 보기 →
공유

Titanis

Windows 프로토콜 라이브러리로, SMB 및 RPC 구현 등을 포함합니다.

저장소 보기

문서 사이트에서 사용자 가이드 보기

소개

Titanis는 Windows 환경과 상호 작용하기 위한 C#으로 작성된 프로토콜 구현 및 명령줄 유틸리티 라이브러리입니다. .NET 8을 사용하며 크로스 플랫폼(Windows 및 Linux)을 지원합니다. 구현된 프로토콜 중 일부는 다음과 같습니다:

  • SMB2 (MS-SMB2)
    • SMB 2.x 및 3.x, 최대 3.1.1
    • 서명 및 암호화와 같은 메시지 보안 기능
    • 파일 시스템 제어 코드 지원 포함 (MS-FSCC)
    • DFS 링크 (MS-DFSC)
  • MSRPC (MS-RPCE)
    • 엔드포인트 매퍼
    • DCOM (MS-DCOM)
    • 디렉터리 복제 (MS-DRSR)
      • Windows Server 2008 및 Windows Server 2025에서 테스트됨
      • MS-ZIP 및 Xpress 압축 모두 지원
      • 개별 객체 또는 전체 파티션의 복제 지원
    • EFS (MS-EFSR)
    • LSA (MS-LSAD 및 MS-LSAT)
    • 원격 레지스트리 (MS-RRP)
      • 백업 시맨틱스 지원 포함
      • SAM 덤프 기능 포함
    • 보안 계정 관리자 (MS-SAMR)
    • 서비스 제어 관리자 (MS-SCMR)
    • 서버 서비스 (MS-SRVS)
    • WMI (MS-WMI 및 MS-WMIO)
    • 디렉터리 복제 (MS-DRSR)
    • EventLog 원격 프로토콜 버전 6.0 (MS-EVEN6)
    • 작업 스케줄러 서비스 원격 프로토콜 (MS-TSCH)
    • 원격 권한 부여 API 프로토콜 (MS-RAA)
    • 방화벽 및 고급 보안 프로토콜 (MS-FASP)
  • LDAP (RFC 4511 및 MS-ADTS의 일부)
  • 보안
    • NTLM (MS-NLMP)
    • Kerberos (RFC4120 및 MS-KILE)
      • 영역 간 참조
      • PKINIT (MS-PKCA 및 RFC 4556)
      • S4U (MS-SFU)
        • S4U2self
        • S4U2proxy
      • 암호화 프로필
        • DES CBC MD5 (RFC3961) (AS 전용)
        • RC4-HMAC (RFC4757)
        • AES 128/256 (RFC3962)
        • .kirbi 및 ccache 파일 지원
        • keytab 파일 지원
      • 비밀번호 변경 / 설정 (RFC3244)
      • FAST / 아머링 및 복합 ID
    • SP-NEGO (MS-SPNG)
  • 통합 SOCKS 5 지원 (-Socks5 매개변수) (RFC1928)

최근 변경 사항은 변경 로그를 참조하세요.

지원되는 인증 시나리오에 대한 개요는 인증을 참조하세요 - 매개변수로 인증을 제어하는 방법을 설명합니다.

이 도구 세트는 운영 환경에 통합할 수 있는 콜백 및 로깅 기능을 구현합니다.

명령줄 도구 목록과 이를 사용하여 수행할 수 있는 작업은 도구 색인을 확인하세요.

대상 독자

  • 보안 연구원 - Windows가 다양한 유형의 요청에 어떻게 반응하는지 연구
  • 침투 테스트 전문가 - 작업을 수행하고 완화 기능이 활성화되어 제대로 작동하는지 테스트
  • 시스템 관리자 - 관리 작업 수행

시작하기

빌드 지침

사용자인 경우 명령줄 유틸리티 목록과 사용 방법은 사용자 가이드를 참조하세요.

개발자인 경우 코드베이스를 개선하는 방법에 대한 정보는 개발자 가이드를 참조하세요.

프로젝트 구성

  • doc/ - 프로젝트 문서
  • src/ - 프로토콜 구현을 위한 소스 코드
  • test/ - 단위 테스트
  • tools/ - 독립 실행형 명령줄 도구
  • samples/ - 라이브러리 사용 방법을 보여주는 샘플 코드

Titanis.sln 내에서 프로젝트는 다음과 같은 기능 영역으로 그룹화됩니다:

  • Base - 다른 구성 요소에서 사용하는 유틸리티
  • Crypto - 암호화 알고리즘 구현
  • Formats - ASN.1과 같은 다양한 형식을 읽고 쓰기 위한 구현
  • Protocols - 네트워크 프로토콜 구현
  • Security - NTLM 및 Kerberos와 같은 보안 프로토콜 구현
  • Test - 단위 테스트
  • Tools - 독립 실행형 명령줄 도구
  • _Build - 빌드 프로세스와 관련된 파일

여러 프로젝트에는 개발 중에 참조한 사양을 참조하는 References.txt라는 파일이 포함되어 있습니다. 소스 코드에는 일반적으로 관련 섹션 번호와 함께 이러한 사양에 대한 참조가 포함되어 있습니다.

도구 다운로드