업데이트로 돌아가기
New releaseSep 30, 2026

openssl openssl-4.0.3

범용 TLS 및 암호화 라이브러리

공유

OpenSSL 프로젝트에 오신 것을 환영합니다

openssl logo

github actions ci badge Nightly OS Zoo ci badge Provider Compatibility Quic Interop Daily checks LFX Health Score

OpenSSL은 전송 계층 보안(TLS, 이전 명칭 SSL), 데이터그램 TLS(DTLS) 및 QUIC 프로토콜을 위한 강력하고 상용 등급의 모든 기능을 갖춘 오픈 소스 툴킷입니다.

프로토콜 구현은 완전한 강도의 범용 암호화 라이브러리를 기반으로 하며, 이 라이브러리는 독립적으로도 사용할 수 있습니다. 또한 FIPS 표준을 준수하도록 검증된 암호화 모듈도 포함되어 있습니다.

OpenSSL은 Eric A. Young과 Tim J. Hudson이 개발한 SSLeay 라이브러리에서 파생되었습니다.

OpenSSL 프로젝트의 공식 홈 페이지는 www.openssl.org입니다.

목차

개요

OpenSSL 툴킷에는 다음이 포함됩니다:

  • libssl TLSv1.3(RFC 8446)까지의 모든 TLS 프로토콜 버전, DTLSv1.3(RFC 9147)까지의 DTLS 프로토콜 버전 및 QUIC 버전 1 프로토콜(RFC 9000)의 구현입니다.

  • libcrypto 완전한 강도의 범용 암호화 라이브러리입니다. TLS 구현의 기반을 구성하지만 독립적으로도 사용할 수 있습니다.

  • openssl OpenSSL 명령줄 도구로, 암호화 작업, 테스트 및 분석을 위한 스위스 아미 나이프입니다. 다음과 같은 용도로 사용할 수 있습니다.

    • 키 매개변수 생성
    • X.509 인증서, CSR 및 CRL 생성
    • 메시지 다이제스트 계산
    • 암호화 및 복호화
    • SSL/TLS/DTLS 및 클라이언트와 서버 테스트
    • QUIC 클라이언트 테스트
    • S/MIME 서명 또는 암호화된 메일 처리
    • 그 외 다수...

다운로드

프로덕션 용도

공식 릴리스의 소스 코드 tarball은 openssl-library.org/source/에서 다운로드할 수 있습니다. OpenSSL 프로젝트는 툴킷을 바이너리 형태로 배포하지 않습니다.

그러나 다양한 운영 체제를 위한 사전 컴파일된 OpenSSL 툴킷 버전이 제공됩니다. 특히 Linux 및 기타 Unix 운영 체제에서는 일반적으로 배포자 또는 공급업체가 제공하는 사전 컴파일된 공유 라이브러리에 링크하는 것이 권장됩니다.

또한 다양한 운영 체제(Windows 포함)용 OpenSSL 바이너리를 생산하는 제3자 목록을 위키의 Binaries 페이지에서 유지 관리하고 있습니다.

테스트 및 개발 용도

테스트 및 개발은 이론적으로 소스 tarball을 사용하여 수행할 수도 있지만, 전체 프로젝트 이력이 포함된 git 저장소의 로컬 복사본을 보유하면 코드베이스에 대한 훨씬 더 많은 통찰력을 얻을 수 있습니다.

주요 OpenSSL Git 저장소는 비공개입니다. github.com/openssl/openssl에 공개 GitHub 미러가 있으며, 이 미러는 모든 커밋마다 전자에서 자동으로 업데이트됩니다.

Git 저장소의 로컬 복사본은 GitHub 미러에서 복제하여 얻을 수 있습니다.

git clone https://github.com/openssl/openssl.git

버그를 수정하거나 새로운 기능을 기여하는 등 OpenSSL에 기여할 의향이 있다면, GitHub 미러를 포크하고 공개 포크를 복제해야 합니다.

git clone https://github.com/yourname/openssl.git

이는 현재 OpenSSL의 모든 개발이 GitHub 풀 리퀘스트를 통해 이루어지기 때문에 필요합니다. 자세한 내용은 기여를 참조하세요.

빌드 및 설치

소스를 얻은 후, OpenSSL 빌드 및 설치에 대한 자세한 지침은 INSTALL 파일을 참조하세요. 일부 플랫폼의 경우 설치 지침이 플랫폼별 문서로 보완됩니다.

이전 버전에서 OpenSSL 3.x로 업그레이드하는 것에 대한 구체적인 참고 사항은 ossl-guide-migration(7ossl) 매뉴얼 페이지에서 확인할 수 있습니다.

문서

README 파일

소스 배포판의 최상위 수준에는 특정 주제에 대한 추가 정보를 포함하는 몇 가지 README.md 파일이 있습니다.

OpenSSL 가이드

OpenSSL Guide 내에 몇 가지 중요한 OpenSSL 주제에 대한 튜토리얼 및 입문 페이지가 있습니다.

매뉴얼 페이지

master 브랜치 및 모든 현재 안정 릴리스의 매뉴얼 페이지는 온라인에서 사용할 수 있습니다.

데모

다양한 OpenSSL 기능을 사용하기 위한 수많은 소스 코드 데모가 demos 하위 폴더에 있습니다.

위키

GitHub Wiki가 있지만 현재는 그다지 활발하지 않습니다.

라이선스

OpenSSL은 Apache License 2.0에 따라 라이선스가 부여되며, 이는 그 조건을 충족하는 한 상업적 및 비상업적 목적으로 자유롭게 사용할 수 있음을 의미합니다.

자세한 내용은 LICENSE.txt 파일을 참조하세요.

지원

연락할 수 있는 다양한 방법이 있습니다. 올바른 채널은 요구 사항에 따라 다릅니다. 자세한 내용은 SUPPORT 파일을 참조하세요.

기여

OpenSSL 프로젝트에 관심이 있고 기여할 의향이 있다면 CONTRIBUTING 파일을 참조하세요.

법적 사항

여러 국가에서 암호화의 사용 또는 수출을 제한하고 있습니다. 이러한 제한의 적용을 받을 가능성이 있는 경우, 암호화 코드를 개발하거나 배포하기 전에 법률 자문을 구해야 합니다.

저작권

Copyright (c) 1998-2026 The OpenSSL Project Authors

Copyright (c) 1995-1998 Eric A. Young, Tim J. Hudson

All rights reserved.

카테고리