업데이트로 돌아가기
New releaseSep 5, 2026

parsedmarc v11.0.1

집계 및 포렌식 DMARC 보고서를 파싱하기 위한 Python 패키지 및 CLI

공유

parsedmarc

Build
Status Code
Coverage PyPI
Package PyPI - Downloads

Kibana의 DMARC 요약 차트 스크린샷

parsedmarc는 DMARC 보고서를 파싱하기 위한 Python 모듈이자 CLI 유틸리티입니다. Elasticsearch 및 Kibana(또는 Splunk)와 함께 사용하거나 OpenSearch 및 Grafana와 함께 사용하면, Agari Brand Protection, Dmarcian, OnDMARC, ProofPoint Email Fraud Defense, Valimail과 같은 상용 DMARC 보고서 처리 서비스에 대한 자체 호스팅 오픈소스 대안으로 동작합니다.

[!NOTE] Domain-based Message Authentication, Reporting, and Conformance (DMARC)는 이메일 인증 프로토콜입니다.

스폰서

이 프로젝트는 한 명의 개발자가 유지 관리합니다. 귀하 또는 귀하의 조직이 이 프로젝트로 혜택을 받고 있다면 제 작업 후원을 고려해 주세요.

기능

  • 집계/rua DMARC 보고서 파싱: 레거시 초안 및 1.0 스키마 (RFC 7489)와 최종 DMARC 표준(RFC 9989)을 위한 새로운 RFC 9990 스키마
  • 실패/ruf DMARC 보고서 파싱 (RFC 6591 및 RFC 9991; 이전에는 포렌식 보고서라고 불림)
  • SMTP TLS Reporting (TLS-RPT, RFC 8460) 보고서 파싱
  • IMAP, Microsoft Graph 또는 Gmail API를 통해 받은 편지함의 보고서를 파싱 가능
  • gzip 또는 zip으로 압축된 보고서를 투명하게 처리
  • 일관된 데이터 구조
  • 간단한 JSON 및/또는 CSV 출력
  • 선택적으로 결과를 이메일로 전송
  • 선택적으로 결과를 Elasticsearch, OpenSearch, Splunk 또는 PostgreSQL로 전송하여 미리 만들어진 대시보드와 함께 사용
  • 선택적으로 결과를 Apache Kafka, Amazon S3, Azure Log Analytics (Microsoft Sentinel), Graylog (GELF) 엔드포인트, syslog 서버, Grafana Loki 또는 HTTP 웹훅으로 전송

Python 호환성

이 프로젝트는 현재 적극적으로 유지 관리되거나 RHEL 또는 Debian의 기본 버전인 다음 Python 버전을 지원합니다.

버전지원 여부이유
< 3.6❌지원 종료 (EOL)
3.6❌RHEL 8에서 사용되지만 프로젝트 종속성에서 지원하지 않음
3.7❌지원 종료 (EOL)
3.8❌지원 종료 (EOL)
3.9❌Debian 11 및 RHEL 9에서 사용되지만 프로젝트 종속성에서 지원하지 않음
3.10✅적극적으로 유지 관리됨
3.11✅적극적으로 유지 관리됨; 2028년 6월까지 지원 (Debian 12)
3.12✅적극적으로 유지 관리됨; 2035년 5월까지 지원 (RHEL 10)
3.13✅적극적으로 유지 관리됨; 2030년 6월까지 지원 (Debian 13)
3.14✅지원됨 (imapclient>=3.1.0 필요)

카테고리