Skip to content
KitploitKITPLOIT
उपकरणएक्सप्लॉइटब्लॉग
Log in
जमा करें
उपकरणएक्सप्लॉइटब्लॉग
जमा करें

हैकिंग, पेनटेस्ट और साइबर सुरक्षा उपकरण आपके सुरक्षा शस्त्रागार के लिए!

Kitploit हैकिंग, साइबर सुरक्षा और पेंटेस्टिंग टूल्स की एक निर्देशिका है। कमजोरियों को खोजने, सिस्टम का विश्लेषण करने, परीक्षण को स्वचालित करने और अपनी सुरक्षा को मजबूत करने के लिए नवीनतम प्रोजेक्ट अपडेट खोजें।

··फ़ीड·संपर्क·गोपनीयता·© 2026 Kitploit

टूल निर्देशिका

श्रेणियाँ

सभी श्रेणियाँ देखें
Loading categories
apache__mina-sshd_CVE-2023-35887_2-9-2 — पूरी तरह से जावा SSH क्लाइंट/सर्वर लाइब्रेरी जो SSH-2 प्रोटोकॉल को लागू करती है, जिसमें कई सिफर, कुंजी विनिमय, प्रमाणीकरण विधियाँ, SFTP, SCP और सुरक्षित दूरस्थ पहुँच के लिए पोर्ट फ़ॉरवर्डिंग का समर्थन है। | Kitploit
उपकरण/GitHubGitHub/shoucheng3/apache__mina-sshd_cve-2023-35887_2-9-2
एन्क्रिप्शन/डिक्रिप्शन उपकरणभेद्यता विश्लेषणनेटवर्क सुरक्षाक्रिप्टोग्राफीपेनिट्रेशन टेस्टिंगउपयोगिताएँ और फ्रेमवर्कप्रमाणीकरणरिमोट एक्सेस टूल

सबसे लोकप्रिय

सभी देखें →

हमारे समुदाय द्वारा सबसे अधिक उपयोग किए जाने वाले उपकरण खोजें।

सभी उपकरण खोजें

हमारे उपकरणों का संग्रह ब्राउज़ करें

सभी उपकरण देखें →
साझा करें
GitHub
shoucheng3/apache__mina-sshd_cve-2023-35887_2-9-2

apache__mina-sshd_CVE-2023-35887_2-9-2

पूरी तरह से जावा SSH क्लाइंट/सर्वर लाइब्रेरी जो SSH-2 प्रोटोकॉल को लागू करती है, जिसमें कई सिफर, कुंजी विनिमय, प्रमाणीकरण विधियाँ, SFTP, SCP और सुरक्षित दूरस्थ पहुँच के लिए पोर्ट फ़ॉरवर्डिंग का समर्थन है।

रिपॉजिटरी देखें
131 साल पहलेअभी तक समीक्षित नहीं

Apache MINA SSHD

Apache MINA SSHD

Apache MINA SSHD एक 100% शुद्ध जावा लाइब्रेरी है जो क्लाइंट और सर्वर दोनों पक्षों पर SSH प्रोटोकॉल का समर्थन करती है। इसका उद्देश्य यूनिक्स ऑपरेटिंग सिस्टम के SSH क्लाइंट या SSH सर्वर का प्रतिस्थापन बनना नहीं है, बल्कि यह Java आधारित अनुप्रयोगों को SSH सहायता प्रदान करती है।

लाइब्रेरी कई I/O बैक-एंड का लाभ उठा सकती है:

  • डिफ़ॉल्ट ट्रांसपोर्ट अंतर्निहित है और Java के AsynchronousSocketChannels का उपयोग करता है।
  • इसके बजाय Apache MINA, एक स्केलेबल और उच्च प्रदर्शन वाली अतुल्यकालिक I/O लाइब्रेरी, का उपयोग किया जा सकता है, या
  • Netty अतुल्यकालिक ईवेंट-संचालित नेटवर्क फ्रेमवर्क भी समर्थित है।

समर्थित मानक

संदर्भ कार्यान्वयन दस्तावेज़ीकरण

  • RFC 4251 - द सिक्योर शेल (SSH) प्रोटोकॉल आर्किटेक्चर
  • RFC 4252 - द सिक्योर शेल (SSH) प्रमाणीकरण प्रोटोकॉल
  • RFC 4253 - द सिक्योर शेल (SSH) ट्रांसपोर्ट लेयर प्रोटोकॉल
  • RFC 4254 - द सिक्योर शेल (SSH) कनेक्शन प्रोटोकॉल
  • RFC 4256 - सिक्योर शेल प्रोटोकॉल (SSH) के लिए जेनेरिक मैसेज एक्सचेंज प्रमाणीकरण
  • RFC 4335 - द सिक्योर शेल (SSH) सत्र चैनल ब्रेक एक्सटेंशन
  • RFC 4344 - द सिक्योर शेल (SSH) ट्रांसपोर्ट लेयर एन्क्रिप्शन मोड
  • RFC 4345 - द सिक्योर शेल (SSH) ट्रांसपोर्ट लेयर प्रोटोकॉल के लिए बेहतर Arcfour मोड
  • RFC 4419 - द सिक्योर शेल (SSH) ट्रांसपोर्ट लेयर प्रोटोकॉल के लिए डिफी-हेलमैन ग्रुप एक्सचेंज
  • RFC 4716 - द सिक्योर शेल (SSH) पब्लिक की फ़ाइल फ़ॉर्मेट
  • RFC 5208 - पब्लिक-की क्रिप्टोग्राफ़ी मानक (PKCS) #8 - संस्करण 1.2
  • RFC 5480 - एलिप्टिक कर्व क्रिप्टोग्राफ़ी विषय पब्लिक की जानकारी
  • RFC 5647 - सिक्योर शेल ट्रांसपोर्ट लेयर प्रोटोकॉल के लिए AES गैलोइस काउंटर मोड
  • RFC 5656 - सिक्योर शेल ट्रांसपोर्ट लेयर में एलिप्टिक कर्व एल्गोरिदम एकीकरण
  • RFC 5915 - एलिप्टिक कर्व प्राइवेट की संरचना
  • RFC 6668 - सिक्योर शेल (SSH) ट्रांसपोर्ट लेयर प्रोटोकॉल के लिए SHA-2 डेटा अखंडता सत्यापन
  • RFC 8160 - सिक्योर शेल (SSH) में IUTF8 टर्मिनल मोड
  • RFC 8268 - सिक्योर शेल (SSH) के लिए अधिक मॉड्यूलर घातांक (MODP) डिफी-हेलमैन (DH) कुंजी विनिमय (KEX) समूह
  • RFC 8308 - सिक्योर शेल (SSH) प्रोटोकॉल में एक्सटेंशन वार्तालाप
    • नोट: - कोड में RFC को लागू करने के लिए हुक शामिल हैं और server-sig-algs एक्सटेंशन के लिए डिफ़ॉल्ट क्लाइंट और सर्वर कार्यान्वयन भी प्रदान करता है।
  • RFC 8332 - सिक्योर शेल (SSH) प्रोटोकॉल में SHA-256 और SHA-512 के साथ RSA कुंजियों का उपयोग
    • नोट: - सर्वर पक्ष डिफ़ॉल्ट रूप से इन हस्ताक्षरों का समर्थन करता है। क्लाइंट पक्ष को विशिष्ट प्रारंभिकीकरण की आवश्यकता होती है - धारा 3.3 और ऊपर उल्लिखित RFC 8308 के लिए हुक भी देखें।
  • RFC 8731 - Curve25519 और Curve448 का उपयोग करके सिक्योर शेल (SSH) कुंजी विनिमय विधि
  • सिक्योर शेल के लिए कुंजी विनिमय (KEX) विधि अद्यतन और अनुशंसाएँ
  • U2F/FIDO सुरक्षा कुंजियों के लिए OpenSSH समर्थन
    • नोट: सर्वर पक्ष डिफ़ॉल्ट रूप से इन कुंजियों का समर्थन करता है। क्लाइंट पक्ष को विशिष्ट प्रारंभिकीकरण की आवश्यकता होती है
  • SSH के लिए OpenSSH सार्वजनिक-की प्रमाणपत्र प्रमाणीकरण प्रणाली
  • SSH प्रॉक्सी जंप
  • SFTP संस्करण 3-6 + एक्सटेंशन
    • supported - DRAFT 05 - धारा 4.4
    • supported2 - DRAFT 13 धारा 5.4
    • versions - DRAFT 09 धारा 4.6
    • vendor-id - DRAFT 09 - धारा 4.4
    • acl-supported - DRAFT 11 - धारा 5.4
    • newline - DRAFT 09 धारा 4.3
    • md5-hash, md5-hash-handle - DRAFT 09 - धारा 9.1.1
    • check-file-handle, check-file-name - DRAFT 09 - धारा 9.1.2
    • copy-file, copy-data - DRAFT 00 - धारा 6, 7
    • space-available - DRAFT 09 - धारा 9.2
    • filename-charset, filename-translation-control - DRAFT 13 - धारा 6 - केवल क्लाइंट पक्ष
    • कई OpenSSH SFTP एक्सटेंशन
  • एंडलेस टारपिट - HOWTO(s) अनुभाग देखें।

कार्यान्वित/उपलब्ध समर्थन

प्रमाणीकरण विधियाँ

  • होस्ट-आधारित, पब्लिक की, OpenSSH होस्ट-आधारित पब्लिक की, कीबोर्ड-इंटरैक्टिव, पासवर्ड

सिफ़र

  • aes128cbc, aes128ctr, aes192cbc, aes192ctr, aes256cbc, aes256ctr, arcfour128, arcfour256, blowfish-cbc, [email protected], [email protected], [email protected], 3des-cbc

डाइजेस्ट

  • md5, sha1, sha224, sha256, sha384, sha512

मैक

  • hmacmd5, hmacmd596, hmacsha1, hmacsha196, hmacsha256, hmacsha512, [email protected] , [email protected], [email protected]

कुंजी विनिमय

  • diffie-hellman-group1-sha1, diffie-hellman-group-exchange-sha256, diffie-hellman-group14-sha1, diffie-hellman-group14-sha256 , diffie-hellman-group15-sha512, diffie-hellman-group16-sha512, diffie-hellman-group17-sha512, diffie-hellman-group18-sha512 , ecdh-sha2-nistp256, ecdh-sha2-nistp384, ecdh-sha2-nistp521, curve25519-sha256, [email protected], curve448-sha512
    • Java 11 से पहले के Java संस्करणों पर, curve25519-sha256, [email protected], या curve448-sha512 के लिए Bouncy Castle आवश्यक है।

संपीड़न

  • none, zlib, [email protected]

हस्ताक्षर/कुंजियाँ

  • ssh-dss, ssh-rsa, rsa-sha2-256, rsa-sha2-512, nistp256, nistp384, nistp521 , ssh-ed25519 (eddsa वैकल्पिक मॉड्यूल आवश्यक है), [email protected], [email protected] , [email protected], [email protected], [email protected] , [email protected], [email protected], [email protected]
टूल डाउनलोड करें