
openssl openssl-4.0.3
Bibliothèque TLS et cryptographique polyvalente
Bienvenue dans le projet OpenSSL
[![logo openssl]][www.openssl.org]
[![badge ci github actions]][github actions ci]
OpenSSL est une boîte à outils Open Source robuste, de qualité commerciale et complète pour les protocoles Transport Layer Security (TLS, anciennement SSL), Datagram TLS (DTLS) et QUIC.
Les implémentations des protocoles sont basées sur une bibliothèque cryptographique polyvalente de pleine puissance, qui peut également être utilisée de manière autonome. Un module cryptographique validé conforme aux normes FIPS est également inclus.
OpenSSL est issu de la bibliothèque SSLeay développée par Eric A. Young et Tim J. Hudson.
La page d'accueil officielle du projet OpenSSL est [www.openssl.org].
Table des matières
- Aperçu
- Téléchargement
- Compilation et installation
- Documentation
- Licence
- Support
- Contribution
- Aspects juridiques
Aperçu
La boîte à outils OpenSSL comprend :
-
libssl une implémentation de toutes les versions du protocole TLS jusqu'à TLSv1.3 ([RFC 8446]), des versions du protocole DTLS jusqu'à DTLSv1.3 ([RFC 9147]) et du protocole QUIC version 1 ([RFC 9000]).
-
libcrypto une bibliothèque cryptographique polyvalente de pleine puissance. Elle constitue la base de l'implémentation TLS, mais peut également être utilisée indépendamment.
-
openssl l'outil en ligne de commande OpenSSL, un couteau suisse pour les tâches cryptographiques, les tests et l'analyse. Il peut être utilisé pour
- la création de paramètres de clés
- la création de certificats X.509, CSR et CRL
- le calcul de condensés de messages
- le chiffrement et le déchiffrement
- les tests SSL/TLS/DTLS client et serveur
- les tests client QUIC
- la gestion du courrier signé ou chiffré S/MIME
- et plus encore...
Téléchargement
Pour une utilisation en production
Les archives du code source des versions officielles peuvent être téléchargées depuis openssl-library.org/source/. Le projet OpenSSL ne distribue pas la boîte à outils sous forme binaire.
Cependant, pour une grande variété de systèmes d'exploitation, des versions précompilées de la boîte à outils OpenSSL sont disponibles. En particulier, sous Linux et les autres systèmes d'exploitation Unix, il est normalement recommandé de se lier aux bibliothèques partagées précompilées fournies par le distributeur ou le fournisseur.
Nous maintenons également une liste de tiers qui produisent des binaires OpenSSL pour divers systèmes d'exploitation (y compris Windows) sur la page [Binaries] de notre wiki.
Pour les tests et le développement
Bien que les tests et le développement puissent en théorie également être effectués à l'aide des archives du code source, disposer d'une copie locale du dépôt git avec l'historique complet du projet vous donne beaucoup plus de perspective sur la base de code.
Le dépôt Git principal d'OpenSSL est privé. Il en existe un miroir GitHub public à l'adresse [github.com/openssl/openssl], qui est mis à jour automatiquement depuis le premier à chaque commit.
Une copie locale du dépôt Git peut être obtenue en le clonant depuis le miroir GitHub à l'aide de
git clone https://github.com/openssl/openssl.git
Si vous avez l'intention de contribuer à OpenSSL, que ce soit pour corriger des bugs ou apporter de nouvelles fonctionnalités, vous devez forker le miroir GitHub et cloner votre fork public à la place.
git clone https://github.com/yourname/openssl.git
Ceci est nécessaire car tout le développement d'OpenSSL se fait de nos jours via des pull requests GitHub. Pour plus de détails, voir Contribution.
Compilation et installation
Après avoir obtenu le code source, consultez le fichier INSTALL pour des instructions détaillées sur la compilation et l'installation d'OpenSSL. Pour certaines plateformes, les instructions d'installation sont complétées par un document spécifique à la plateforme.
- Notes pour les plateformes de type UNIX
- Notes pour les plateformes Android
- Notes pour les plateformes Windows
- Notes pour la plateforme DOS avec DJGPP
- Notes pour la plateforme OpenVMS
- Notes sur Perl
- Notes sur Valgrind
Des notes spécifiques sur la mise à niveau vers OpenSSL 3.x depuis des versions précédentes sont disponibles dans la page de manuel [ossl-guide-migration(7ossl)].
Documentation
Fichiers README
Il y a quelques fichiers README.md à la racine de la distribution du code source contenant des informations supplémentaires sur des sujets spécifiques.
- Informations sur l'implémentation du protocole QUIC d'OpenSSL
- Informations sur l'architecture des fournisseurs OpenSSL
- Informations sur l'utilisation du module validé FIPS d'OpenSSL
Le guide OpenSSL
Il existe quelques pages de tutoriel et d'introduction sur certains sujets importants d'OpenSSL au sein du [OpenSSL Guide].
Pages de manuel
Les pages de manuel pour la branche master et toutes les versions stables actuelles sont disponibles en ligne.
Démos
Il existe de nombreuses démos de code source pour l'utilisation de diverses capacités d'OpenSSL dans le sous-dossier demos.
Wiki
Il existe un [GitHub Wiki] qui n'est actuellement pas très actif.
Licence
OpenSSL est sous licence Apache License 2.0, ce qui signifie que vous êtes libre de l'obtenir et de l'utiliser à des fins commerciales et non commerciales tant que vous remplissez ses conditions.
Voir le fichier LICENSE.txt pour plus de détails.