Skip to content
KitploitKITPLOIT
HerramientasExploitsBlog
Log in
Enviar
HerramientasExploitsBlog
Enviar

¡Herramientas de Hacking, PenTest y Ciberseguridad para tu Arsenal de Seguridad!

Kitploit es un directorio de herramientas de hacking, ciberseguridad y pentesting. Descubre las últimas actualizaciones de proyectos para encontrar vulnerabilidades, analizar sistemas, automatizar pruebas y fortalecer tu seguridad.

FeedsContactoPrivacidad© 2026 Kitploit

Directorio de Herramientas

Categorías

Ver todas las categorías
Loading categories
Titanis — Biblioteca de protocolos de Windows, que incluye implementaciones de SMB y RPC, entre otras. | Kitploit
Herramientas/GitHubGitHub/trustedsec/titanis
Escalada de PrivilegiosExplotaciónMovimiento LateralRecopilación de InformaciónSeguridad de RedesCriptografíaPruebas de PenetraciónUtilidades y FrameworksAutenticaciónRed Teaming
GitHubtrustedsec/titanis
8238637hace 27 díasRevisado por Kitploit

Más Populares

Ver todos →

Descubre las herramientas más usadas por nuestra comunidad.

Explora todas las herramientas

Explora nuestra colección de herramientas

Ver todas las herramientas →
Compartir

Titanis

Biblioteca de protocolos de Windows, que incluye implementaciones de SMB y RPC, entre otras.

Ver Repositorio

Ver la Guía del Usuario en el sitio de documentación

Introducción

Titanis es una biblioteca de implementaciones de protocolos y utilidades de línea de comandos, escrita en C#, para interactuar con entornos Windows. Utiliza .NET 8 y es multiplataforma (Windows y Linux). Algunos de los protocolos implementados:

  • SMB2 (MS-SMB2)
    • SMB 2.x y 3.x hasta 3.1.1
    • Características de seguridad de mensajes como firma y cifrado
    • Incluye soporte para códigos de control del sistema de archivos (MS-FSCC)
    • Enlaces DFS (MS-DFSC)
  • MSRPC (MS-RPCE)
    • Asignador de endpoints
    • DCOM (MS-DCOM)
    • Replicación de directorios (MS-DRSR)
      • Probado con Windows Server 2008 y Windows Server 2025
      • Soporta compresión MS-ZIP y Xpress
      • Soporta replicación de objetos individuales o particiones completas
    • EFS (MS-EFSR)
    • LSA (MS-LSAD y MS-LSAT)
    • Registro remoto (MS-RRP)
      • Incluye soporte para semántica de respaldo
      • Incluye funcionalidad de volcado de SAM
    • Administrador de cuentas de seguridad (MS-SAMR)
    • Administrador de control de servicios (MS-SCMR)
    • Servicio de servidor (MS-SRVS)
    • WMI (MS-WMI y MS-WMIO)
    • Replicación de directorios (MS-DRSR)
    • Protocolo de acceso remoto a EventLog versión 6.0 (MS-EVEN6)
    • Protocolo de acceso remoto al servicio Programador de tareas (MS-TSCH)
    • Protocolo de API de autorización remota (MS-RAA)
    • Protocolo de firewall y seguridad avanzada (MS-FASP)
  • LDAP (RFC 4511 y partes de MS-ADTS)
  • Seguridad
    • NTLM (MS-NLMP)
    • Kerberos (RFC4120 y MS-KILE)
      • Referencias entre dominios
      • PKINIT (MS-PKCA y RFC 4556)
      • S4U (MS-SFU)
        • S4U2self
        • S4U2proxy
      • Perfiles de cifrado
        • DES CBC MD5 (RFC3961) (solo AS)
        • RC4-HMAC (RFC4757)
        • AES 128/256 (RFC3962)
        • Soporte para archivos .kirbi y ccache
        • Soporte para archivos keytab
      • Cambiar / establecer contraseña (RFC3244)
      • FAST / Armoring e identidad compuesta
    • SP-NEGO (MS-SPNG)
  • Soporte integrado de SOCKS 5 (parámetro -Socks5) (RFC1928)

Para cambios recientes, consulte el registro de cambios

Para una descripción general de los escenarios de autenticación soportados, consulte Autenticación - Describe cómo controlar la autenticación con parámetros

El conjunto de herramientas implementa callbacks y características de registro para integrarse en su entorno operativo.

Para obtener una lista de herramientas de línea de comandos y tareas que puede realizar con ellas, consulte el Índice de herramientas

Público objetivo

  • Investigadores de seguridad - Investigar cómo reacciona Windows ante diversos tipos de solicitudes
  • Pentesters - Realizar acciones y probar si las mitigaciones están habilitadas y funcionando correctamente
  • Administradores de sistemas - Realizar tareas administrativas

Primeros pasos

Instrucciones de compilación

Si es usuario, consulte la Guía del Usuario para obtener una lista de utilidades de línea de comandos y cómo usarlas.

Si es desarrollador, consulte la Guía del Desarrollador para obtener información sobre cómo mejorar la base de código.

Organización del proyecto

  • doc/ - Documentación del proyecto
  • src/ - Código fuente de las implementaciones de protocolos
  • test/ - Pruebas unitarias
  • tools/ - Herramientas de línea de comandos independientes
  • samples/ - Código de ejemplo que demuestra cómo usar las bibliotecas

Dentro de Titanis.sln, los proyectos se agrupan en las siguientes áreas funcionales:

  • Base - Utilidades usadas por otros componentes
  • Crypto - Implementación de algoritmos criptográficos
  • Formats - Implementaciones para leer y escribir diversos formatos, como ASN.1
  • Protocols - Implementaciones de protocolos de red
  • Security - Implementaciones de protocolos de seguridad, como NTLM y Kerberos
  • Test - Pruebas unitarias
  • Tools - Herramientas de línea de comandos independientes
  • _Build - Archivos relevantes para el proceso de compilación.

Varios de los proyectos contienen un archivo llamado References.txt que hace referencia a las especificaciones consultadas durante el desarrollo. El código fuente contiene referencias a estas especificaciones, generalmente junto con el número de sección correspondiente.

Descargar herramienta