Skip to content
KitploitKITPLOIT
HerramientasExploitsBlog
Log in
Enviar
HerramientasExploitsBlog
Enviar

¡Herramientas de Hacking, PenTest y Ciberseguridad para tu Arsenal de Seguridad!

Kitploit es un directorio de herramientas de hacking, ciberseguridad y pentesting. Descubre las últimas actualizaciones de proyectos para encontrar vulnerabilidades, analizar sistemas, automatizar pruebas y fortalecer tu seguridad.

··Feeds·Contacto·Privacidad·© 2026 Kitploit

Directorio de Herramientas

Categorías

Ver todas las categorías
Loading categories
apache__mina-sshd_CVE-2023-35887_2-9-2 — Biblioteca de cliente/servidor SSH Java pura que implementa el protocolo SSH-2 con soporte para múltiples cifrados, intercambios de claves, métodos de autenticación, SFTP, SCP y reenvío de puertos para acceso remoto seguro. | Kitploit
Herramientas/GitHubGitHub/shoucheng3/apache__mina-sshd_cve-2023-35887_2-9-2
Herramientas de Cifrado/DescifradoAnálisis de VulnerabilidadesSeguridad de RedesCriptografíaPruebas de PenetraciónUtilidades y FrameworksAutenticaciónHerramienta de Acceso Remoto

Más Populares

Ver todos →

Descubre las herramientas más usadas por nuestra comunidad.

Explora todas las herramientas

Explora nuestra colección de herramientas

Ver todas las herramientas →
Compartir
GitHubshoucheng3/apache__mina-sshd_cve-2023-35887_2-9-2

apache__mina-sshd_CVE-2023-35887_2-9-2

Biblioteca de cliente/servidor SSH Java pura que implementa el protocolo SSH-2 con soporte para múltiples cifrados, intercambios de claves, métodos de autenticación, SFTP, SCP y reenvío de puertos para acceso remoto seguro.

Ver Repositorio
12hace 1 añoAún no revisado

Apache MINA SSHD

Apache MINA SSHD

Apache MINA SSHD es una biblioteca 100% Java pura para dar soporte a los protocolos SSH tanto en el lado del cliente como en el del servidor. No pretende ser un reemplazo del cliente SSH o del servidor SSH de los sistemas operativos Unix, sino proporcionar soporte para aplicaciones basadas en Java que requieran compatibilidad con SSH.

La biblioteca puede aprovechar varios back-ends de E/S:

  • El transporte predeterminado está integrado y utiliza AsynchronousSocketChannels de Java.
  • Apache MINA, una biblioteca de E/S asíncrona escalable y de alto rendimiento, se puede utilizar en su lugar, o
  • también es compatible con Netty, el framework de red asíncrono y dirigido por eventos.

Estándares admitidos

Documentación de implementación de referencia

  • RFC 4251 - The Secure Shell (SSH) Protocol Architecture
  • RFC 4252 - The Secure Shell (SSH) Authentication Protocol
  • RFC 4253 - The Secure Shell (SSH) Transport Layer Protocol
  • RFC 4254 - The Secure Shell (SSH) Connection Protocol
  • RFC 4256 - Generic Message Exchange Authentication for the Secure Shell Protocol (SSH)
  • RFC 4335 - The Secure Shell (SSH) Session Channel Break Extension
  • RFC 4344 - The Secure Shell (SSH) Transport Layer Encryption Modes
  • RFC 4345 - Improved Arcfour Modes for the Secure Shell (SSH) Transport Layer Protocol
  • RFC 4419 - Diffie-Hellman Group Exchange for the Secure Shell (SSH) Transport Layer Protocol
  • RFC 4716 - The Secure Shell (SSH) Public Key File Format
  • RFC 5208 - Public-Key Cryptography Standards (PKCS) #8 - version 1.2
  • RFC 5480 - Elliptic Curve Cryptography Subject Public Key Information
  • RFC 5647 - AES Galois Counter Mode for the Secure Shell Transport Layer Protocol
  • RFC 5656 - Elliptic Curve Algorithm Integration in the Secure Shell Transport Layer
  • RFC 5915 - Elliptic Curve Private Key Structure
  • RFC 6668 - SHA-2 Data Integrity Verification for the Secure Shell (SSH) Transport Layer Protocol
  • RFC 8160 - IUTF8 Terminal Mode in Secure Shell (SSH)
  • RFC 8268 - More Modular Exponentiation (MODP) Diffie-Hellman (DH) Key Exchange (KEX) Groups for Secure Shell (SSH)
  • RFC 8308 - Extension Negotiation in the Secure Shell (SSH) Protocol
    • Nota: - el código contiene hooks para implementar el RFC y también proporciona una implementación predeterminada de cliente y servidor para las extensiones server-sig-algs.
  • RFC 8332 - Use of RSA Keys with SHA-256 and SHA-512 in the Secure Shell (SSH) Protocol
    • Nota: - el lado del servidor admite estas firmas de forma predeterminada. El lado del cliente requiere una inicialización específica - ver sección 3.3 y también los hooks mencionados anteriormente para RFC 8308.
  • RFC 8731 - Secure Shell (SSH) Key Exchange Method Using Curve25519 and Curve448
  • Key Exchange (KEX) Method Updates and Recommendations for Secure Shell
  • OpenSSH support for U2F/FIDO security keys
    • Nota: el lado del servidor admite estas claves de forma predeterminada. El lado del cliente requiere una inicialización específica
  • OpenSSH public-key certificate authentication system for use by SSH
  • SSH proxy jumps
  • SFTP versiones 3-6 + extensiones
    • supported - DRAFT 05 - section 4.4
    • supported2 - DRAFT 13 section 5.4
    • versions - DRAFT 09 Section 4.6
    • vendor-id - DRAFT 09 - section 4.4
    • acl-supported - DRAFT 11 - section 5.4
    • newline - DRAFT 09 Section 4.3
    • md5-hash, md5-hash-handle - DRAFT 09 - section 9.1.1
    • check-file-handle, check-file-name - DRAFT 09 - section 9.1.2
    • copy-file, copy-data - DRAFT 00 - sections 6, 7
    • space-available - DRAFT 09 - section 9.2
    • filename-charset, filename-translation-control - DRAFT 13 - section 6 - solo lado del cliente
    • Varias extensiones SFTP de OpenSSH
  • Endless tarpit - ver sección HOWTO(s).

Soporte implementado/disponible

Métodos de autenticación

  • hostbased, publickey, OpenSSH host-based public-key, keyboard-interactive, password

Cifradores

  • aes128cbc, aes128ctr, aes192cbc, aes192ctr, aes256cbc, aes256ctr, arcfour128, arcfour256, blowfish-cbc, [email protected], [email protected], [email protected], 3des-cbc

Dígests

  • md5, sha1, sha224, sha256, sha384, sha512

Macs

  • hmacmd5, hmacmd596, hmacsha1, hmacsha196, hmacsha256, hmacsha512, [email protected] , [email protected], [email protected]

Intercambio de claves

  • diffie-hellman-group1-sha1, diffie-hellman-group-exchange-sha256, diffie-hellman-group14-sha1, diffie-hellman-group14-sha256 , diffie-hellman-group15-sha512, diffie-hellman-group16-sha512, diffie-hellman-group17-sha512, diffie-hellman-group18-sha512 , ecdh-sha2-nistp256, ecdh-sha2-nistp384, ecdh-sha2-nistp521, curve25519-sha256, [email protected], curve448-sha512
    • En versiones de Java anteriores a Java 11, se requiere Bouncy Castle para curve25519-sha256, [email protected] o curve448-sha512.

Compresiones

  • none, zlib, [email protected]

Firmas/Claves

Descargar herramienta