Skip to content
KitploitKITPLOIT
ToolsExploitsBlog
Log in
Einreichen
ToolsExploitsBlog
Einreichen

Hacking-, PenTest- und Cybersicherheits-Tools für Ihr Sicherheitsarsenal!

Kitploit ist ein Verzeichnis von Hacking-, Cybersicherheits- und Pentesting-Tools. Entdecken Sie die neuesten Projekt-Updates, um Schwachstellen zu finden, Systeme zu analysieren, Tests zu automatisieren und Ihre Sicherheit zu stärken.

··Feeds·Kontakt·Datenschutz·© 2026 Kitploit

Tool-Verzeichnis

Kategorien

Alle Kategorien anzeigen
Loading categories
apache__mina-sshd_CVE-2023-35887_2-9-2 — Reine Java SSH-Client/Server-Bibliothek, die das SSH-2-Protokoll implementiert und mehrere Verschlüsselungsverfahren, Schlüsselaustausche, Authentifizierungsmethoden, SFTP, SCP sowie Portweiterleitung für sicheren Fernzugriff unterstützt. | Kitploit
Tools/GitHubGitHub/shoucheng3/apache__mina-sshd_cve-2023-35887_2-9-2
Verschlüsselungs-/EntschlüsselungstoolsSchwachstellenanalyseNetzwerksicherheitKryptographiePenetrationstestsDienstprogramme & FrameworksAuthentifizierungRemote-Access-Tool

Beliebteste

Alle anzeigen →

Entdecken Sie die meistgenutzten Tools unserer Community.

Alle Tools erkunden

Durchsuchen Sie unsere Tool-Sammlung

Alle Tools anzeigen →
Teilen
GitHubshoucheng3/apache__mina-sshd_cve-2023-35887_2-9-2

apache__mina-sshd_CVE-2023-35887_2-9-2

Reine Java SSH-Client/Server-Bibliothek, die das SSH-2-Protokoll implementiert und mehrere Verschlüsselungsverfahren, Schlüsselaustausche, Authentifizierungsmethoden, SFTP, SCP sowie Portweiterleitung für sicheren Fernzugriff unterstützt.

Repository anzeigen
12vor 1 JahrNoch nicht geprüft

Apache MINA SSHD

Apache MINA SSHD

Apache MINA SSHD ist eine zu 100% reine Java-Bibliothek zur Unterstützung der SSH-Protokolle sowohl auf Client- als auch auf Serverseite. Sie ist nicht als Ersatz für den SSH-Client oder SSH-Server von Unix-Betriebssystemen gedacht, sondern bietet Unterstützung für Java-basierte Anwendungen, die SSH benötigen.

Die Bibliothek kann mehrere I/O-Backends nutzen:

  • Der standardmäßige Transport ist integriert und verwendet die AsynchronousSocketChannels von Java.
  • Apache MINA, eine skalierbare und leistungsstarke asynchrone I/O-Bibliothek, kann stattdessen verwendet werden, oder
  • das asynchrone ereignisgesteuerte Netzwerk-Framework Netty wird ebenfalls unterstützt.

Unterstützte Standards

Dokumentation zur Referenzimplementierung

  • RFC 4251 - The Secure Shell (SSH) Protocol Architecture (Architektur des Secure Shell (SSH) Protokolls)
  • RFC 4252 - The Secure Shell (SSH) Authentication Protocol (Authentifizierungsprotokoll für Secure Shell (SSH))
  • RFC 4253 - The Secure Shell (SSH) Transport Layer Protocol (Transportschichtprotokoll für Secure Shell (SSH))
  • RFC 4254 - The Secure Shell (SSH) Connection Protocol (Verbindungsprotokoll für Secure Shell (SSH))
  • RFC 4256 - Generic Message Exchange Authentication for the Secure Shell Protocol (SSH) (Generische Nachrichtenaustausch-Authentifizierung für das Secure Shell Protokoll (SSH))
  • RFC 4335 - The Secure Shell (SSH) Session Channel Break Extension (Erweiterung für Session-Channel-Unterbrechung für Secure Shell (SSH))
  • RFC 4344 - The Secure Shell (SSH) Transport Layer Encryption Modes (Verschlüsselungsmodi der Transportschicht für Secure Shell (SSH))
  • RFC 4345 - Improved Arcfour Modes for the Secure Shell (SSH) Transport Layer Protocol (Verbesserte Arcfour-Modi für das Transportschichtprotokoll von Secure Shell (SSH))
  • RFC 4419 - Diffie-Hellman Group Exchange for the Secure Shell (SSH) Transport Layer Protocol (Diffie-Hellman-Gruppenaustausch für das Secure Shell (SSH) Transportschichtprotokoll)
  • RFC 4716 - The Secure Shell (SSH) Public Key File Format (Format öffentlicher Schlüsseldateien für Secure Shell (SSH))
  • RFC 5208 - Public-Key Cryptography Standards (PKCS) #8 - version 1.2 (Public-Key Cryptography Standards (PKCS) #8 - Version 1.2)
  • RFC 5480 - Elliptic Curve Cryptography Subject Public Key Information (Informationen zu öffentlichen Schlüsseln für Elliptische-Kurven-Kryptografie)
  • RFC 5647 - AES Galois Counter Mode for the Secure Shell Transport Layer Protocol (AES Galois Counter Mode für das Secure Shell Transportschichtprotokoll)
  • RFC 5656 - Elliptic Curve Algorithm Integration in the Secure Shell Transport Layer (Integration von Elliptische-Kurven-Algorithmen in die Secure Shell Transportschicht)
  • RFC 5915 - Elliptic Curve Private Key Structure (Struktur privater Schlüssel für Elliptische Kurven)
  • RFC 6668 - SHA-2 Data Integrity Verification for the Secure Shell (SSH) Transport Layer Protocol (SHA-2-Datenintegritätsprüfung für das Secure Shell (SSH) Transportschichtprotokoll)
  • RFC 8160 - IUTF8 Terminal Mode in Secure Shell (SSH) (IUTF8-Terminalmodus in Secure Shell (SSH))
  • RFC 8268 - More Modular Exponentiation (MODP) Diffie-Hellman (DH) Key Exchange (KEX) Groups for Secure Shell (SSH) (Weitere Modular-Exponentiation (MODP) Diffie-Hellman (DH) Schlüsselaustausch (KEX)-Gruppen für Secure Shell (SSH))
  • RFC 8308 - Extension Negotiation in the Secure Shell (SSH) Protocol (Aushandlung von Erweiterungen im Secure Shell (SSH) Protokoll)
    • Hinweis: - der Code enthält Hooks zur Implementierung des RFC und stellt auch Standard-Client- und Server-Implementierungen für die server-sig-algs-Erweiterungen bereit.
  • RFC 8332 - Use of RSA Keys with SHA-256 and SHA-512 in the Secure Shell (SSH) Protocol (Verwendung von RSA-Schlüsseln mit SHA-256 und SHA-512 im Secure Shell (SSH) Protokoll)
    • Hinweis: - die Serverseite unterstützt diese Signaturen standardmäßig. Die Client-Seite erfordert eine spezifische Initialisierung - siehe Abschnitt 3.3 und auch die oben genannten Hooks für RFC 8308.
  • RFC 8731 - Secure Shell (SSH) Key Exchange Method Using Curve25519 and Curve448 (Schlüsselaustauschmethode für Secure Shell (SSH) mit Curve25519 und Curve448)
  • Key Exchange (KEX) Method Updates and Recommendations for Secure Shell (Aktualisierungen und Empfehlungen für Schlüsselaustausch (KEX)-Methoden für Secure Shell)
  • OpenSSH support for U2F/FIDO security keys (OpenSSH-Unterstützung für U2F/FIDO-Sicherheitsschlüssel)
    • Hinweis: die Serverseite unterstützt diese Schlüssel standardmäßig. Die Client-Seite erfordert eine spezifische Initialisierung.
  • OpenSSH public-key certificate authentication system for use by SSH (OpenSSH Public-Key-Zertifikat-Authentifizierungssystem zur Verwendung durch SSH)
  • SSH-Proxy-Sprünge
  • SFTP Version 3-6 + Erweiterungen
    • supported - DRAFT 05 - section 4.4
    • supported2 - DRAFT 13 section 5.4
    • versions - DRAFT 09 Section 4.6
    • vendor-id - DRAFT 09 - section 4.4
    • acl-supported - DRAFT 11 - section 5.4
    • newline - DRAFT 09 Section 4.3
    • md5-hash, md5-hash-handle - DRAFT 09 - section 9.1.1
    • check-file-handle, check-file-name - DRAFT 09 - section 9.1.2
    • copy-file, copy-data - DRAFT 00 - sections 6, 7
    • space-available - DRAFT 09 - section 9.2
    • filename-charset, filename-translation-control - DRAFT 13 - section 6 - nur Client-Seite
Tool herunterladen