Skip to content
KitploitKITPLOIT
أدواتالمدونة
Log in
إرسال
أدواتالمدونة
إرسال

أدوات الاختراق واختبار الاختراق والأمن السيبراني لترسانتك الأمنية!

Kitploit هو دليل لأدوات الاختراق والأمن السيبراني واختبار الاختراق. اكتشف آخر تحديثات المشاريع للعثور على الثغرات وتحليل الأنظمة وأتمتة الاختبارات وتعزيز أمنك.

··الخلاصات·اتصال·الخصوصية·© 2026 Kitploit

دليل الأدوات

الفئات

عرض جميع الفئات
Loading categories
apache__mina-sshd_CVE-2023-35887_2-9-2 — مكتبة SSH عميل/خادم جافا نقية تنفذ بروتوكول SSH-2 مع دعم تشفيرات متعددة وتبادلات مفاتيح وطرق مصادقة وSFTP وSCP وإعادة توجيه المنافذ للوصول الآمن عن بعد. | Kitploit
أدوات/GitHubGitHub/shoucheng3/apache__mina-sshd_cve-2023-35887_2-9-2
أدوات التشفير/فك التشفيرتحليل الثغرات الأمنيةأمن الشبكاتالتشفيراختبار الاختراقالأدوات والمكوناتالمصادقةأداة الوصول عن بعد

الأكثر شعبية

عرض الكل →

اكتشف الأدوات الأكثر استخدامًا من قبل مجتمعنا.

استكشف جميع الأدوات

تصفح مجموعتنا من الأدوات

عرض جميع الأدوات →
مشاركة
GitHub
shoucheng3/apache__mina-sshd_cve-2023-35887_2-9-2

apache__mina-sshd_CVE-2023-35887_2-9-2

مكتبة SSH عميل/خادم جافا نقية تنفذ بروتوكول SSH-2 مع دعم تشفيرات متعددة وتبادلات مفاتيح وطرق مصادقة وSFTP وSCP وإعادة توجيه المنافذ للوصول الآمن عن بعد.

عرض المستودع
13منذ سنة واحدةلم تتم المراجعة بعد

Apache MINA SSHD

Apache MINA SSHD

Apache MINA SSHD هي مكتبة جافا نقية 100% لدعم بروتوكولات SSH على جانبي العميل والخادم. لا تهدف إلى أن تكون بديلاً عن عميل SSH أو خادم SSH من أنظمة تشغيل يونكس، بل توفر الدعم للتطبيقات القائمة على جافا التي تتطلب دعم SSH.

يمكن للمكتبة الاستفادة من عدة واجهات خلفية للإدخال/الإخراج:

  • النقل الافتراضي مدمج ويستخدم AsynchronousSocketChannels الخاصة بجافا.
  • Apache MINA، وهي مكتبة إدخال/إخراج غير متزامنة قابلة للتوسع وعالية الأداء، يمكن استخدامها بدلاً منه، أو
  • إطار عمل الشبكات غير المتزامن القائم على الأحداث Netty مدعوم أيضًا.

المعايير المدعومة

توثيق التنفيذ المرجعي

  • RFC 4251 - بنية بروتوكول Secure Shell (SSH)
  • RFC 4252 - بروتوكول مصادقة Secure Shell (SSH)
  • RFC 4253 - بروتوكول طبقة النقل لـ Secure Shell (SSH)
  • RFC 4254 - بروتوكول الاتصال لـ Secure Shell (SSH)
  • RFC 4256 - مصادقة تبادل الرسائل العامة لبروتوكول Secure Shell (SSH)
  • RFC 4335 - امتداد كسر قناة الجلسة لـ Secure Shell (SSH)
  • RFC 4344 - أوضاع تشفير طبقة النقل لـ Secure Shell (SSH)
  • RFC 4345 - أوضاع Arcfour المحسّنة لبروتوكول طبقة النقل لـ Secure Shell (SSH)
  • RFC 4419 - تبادل مجموعة Diffie-Hellman لبروتوكول طبقة النقل لـ Secure Shell (SSH)
  • RFC 4716 - تنسيق ملف المفتاح العام لـ Secure Shell (SSH)
  • RFC 5208 - معايير تشفير المفتاح العام (PKCS) #8 - الإصدار 1.2
  • RFC 5480 - معلومات المفتاح العام لموضوع تشفير المنحنى الإهليلجي
  • RFC 5647 - وضع Galois Counter لـ AES لبروتوكول طبقة النقل لـ Secure Shell
  • RFC 5656 - دمج خوارزمية المنحنى الإهليلجي في طبقة النقل لـ Secure Shell
  • RFC 5915 - بنية المفتاح الخاص للمنحنى الإهليلجي
  • RFC 6668 - التحقق من سلامة البيانات باستخدام SHA-2 لبروتوكول طبقة النقل لـ Secure Shell (SSH)
  • RFC 8160 - وضع طرفية IUTF8 في Secure Shell (SSH)
  • RFC 8268 - المزيد من مجموعات تبادل المفاتيح (KEX) Diffie-Hellman (DH) ذات الأس المعياري (MODP) لـ Secure Shell (SSH)
  • RFC 8308 - التفاوض على الامتدادات في بروتوكول Secure Shell (SSH)
    • ملاحظة: - يحتوي الكود على خطافات لتنفيذ RFC ويوفر أيضًا تنفيذًا افتراضيًا للعميل والخادم لامتدادات server-sig-algs.
  • RFC 8332 - استخدام مفاتيح RSA مع SHA-256 و SHA-512 في بروتوكول Secure Shell (SSH)
    • ملاحظة: - يدعم جانب الخادم هذه التوقيعات افتراضيًا. يتطلب جانب العميل تهيئة محددة - انظر القسم 3.3 وكذلك الخطافات المذكورة أعلاه لـ RFC 8308.
  • RFC 8731 - طريقة تبادل مفاتيح Secure Shell (SSH) باستخدام Curve25519 و Curve448
  • تحديثات وتوصيات طريقة تبادل المفاتيح (KEX) لـ Secure Shell
  • دعم OpenSSH لمفاتيح الأمان U2F/FIDO
    • ملاحظة: يدعم جانب الخادم هذه المفاتيح افتراضيًا. يتطلب جانب العميل تهيئة محددة
  • نظام مصادقة شهادات المفتاح العام من OpenSSH لاستخدامه عبر SSH
  • قفزات SSH عبر البروكسي
  • SFTP الإصدارات 3-6 + الامتدادات
    • supported - DRAFT 05 - القسم 4.4
    • supported2 - DRAFT 13 القسم 5.4
    • versions - DRAFT 09 القسم 4.6
    • vendor-id - DRAFT 09 - القسم 4.4
    • acl-supported - DRAFT 11 - القسم 5.4
    • newline - DRAFT 09 القسم 4.3
    • md5-hash, md5-hash-handle - DRAFT 09 - القسم 9.1.1
    • check-file-handle, check-file-name - DRAFT 09 - القسم 9.1.2
    • copy-file, copy-data - DRAFT 00 - القسمان 6 و 7
    • space-available - DRAFT 09 - القسم 9.2
    • filename-charset, filename-translation-control - DRAFT 13 - القسم 6 - فقط جانب العميل
    • العديد من امتدادات OpenSSH SFTP
  • فخ لا نهائي - انظر قسم HOWTO(s).

الدعم المنفذ/المتاح

طرق المصادقة

  • hostbased, publickey, مفتاح عام قائم على المضيف من OpenSSH, keyboard-interactive, password

التشفيرات

  • aes128cbc, aes128ctr, aes192cbc, aes192ctr, aes256cbc, aes256ctr, arcfour128, arcfour256, blowfish-cbc, [email protected], [email protected], [email protected], 3des-cbc

الملخصات

  • md5, sha1, sha224, sha256, sha384, sha512

خوارزميات MAC

  • hmacmd5, hmacmd596, hmacsha1, hmacsha196, hmacsha256, hmacsha512, [email protected] , [email protected], [email protected]

تبادل المفاتيح

  • diffie-hellman-group1-sha1, diffie-hellman-group-exchange-sha256, diffie-hellman-group14-sha1, diffie-hellman-group14-sha256 , diffie-hellman-group15-sha512, diffie-hellman-group16-sha512, diffie-hellman-group17-sha512, diffie-hellman-group18-sha512 , ecdh-sha2-nistp256, ecdh-sha2-nistp384, ecdh-sha2-nistp521, curve25519-sha256, [email protected], curve448-sha512
    • في إصدارات جافا قبل Java 11، تكون Bouncy Castle مطلوبة لـ curve25519-sha256 أو [email protected] أو curve448-sha512.

الضغط

  • none, zlib, [email protected]

التوقيعات/المفاتيح

  • ssh-dss, ssh-rsa, rsa-sha2-256, rsa-sha2-512, nistp256, nistp384, nistp521 , ssh-ed25519 (يتطلب الوحدة الاختيارية eddsa), [email protected], [email protected] , [email protected], [email protected], [email protected] , [email protected], [email protected], [email protected]
تنزيل الأداة