Skip to content
KitploitKITPLOIT
ИнструментыЭксплойтыБлог
Log in
Отправить
ИнструментыЭксплойтыБлог
Отправить

Инструменты для хакинга, пентеста и кибербезопасности — ваш арсенал защиты!

Kitploit — это каталог инструментов для хакинга, кибербезопасности и пентестинга. Находите последние обновления проектов для поиска уязвимостей, анализа систем, автоматизации тестирования и усиления вашей безопасности.

··Ленты·Контакты·Конфиденциальность·© 2026 Kitploit

Каталог инструментов

Категории

Все категории
Loading categories
apache__mina-sshd_CVE-2023-35887_2-9-2 — Pure Java-библиотека SSH-клиента/сервера, реализующая протокол SSH-2 с поддержкой множества шифров, обмена ключами, методов аутентификации, SFTP, SCP и проброса портов для безопасного удалённого доступа. | Kitploit
Инструменты/GitHubGitHub/shoucheng3/apache__mina-sshd_cve-2023-35887_2-9-2
Инструменты шифрования/дешифрованияАнализ уязвимостейСетевая безопасностьКриптографияТестирование на ПроникновениеУтилиты и фреймворкиАутентификацияИнструмент Удаленного Доступа

Популярное

Смотреть все →

Откройте для себя самые используемые инструменты нашего сообщества.

Изучить все инструменты

Просмотрите нашу коллекцию инструментов

Смотреть все инструменты →
Поделиться
GitHubshoucheng3/apache__mina-sshd_cve-2023-35887_2-9-2

apache__mina-sshd_CVE-2023-35887_2-9-2

Pure Java-библиотека SSH-клиента/сервера, реализующая протокол SSH-2 с поддержкой множества шифров, обмена ключами, методов аутентификации, SFTP, SCP и проброса портов для безопасного удалённого доступа.

Репозиторий
121 год назадЕщё не проверено

Apache MINA SSHD

Apache MINA SSHD

Apache MINA SSHD — это библиотека на 100% чистой Java, обеспечивающая поддержку протоколов SSH как на стороне клиента, так и на стороне сервера. Она не ставит целью заменить SSH-клиент или SSH-сервер операционных систем Unix, а скорее предоставляет поддержку для приложений на базе Java, которым требуется поддержка SSH.

Библиотека может использовать несколько бэкендов ввода-вывода:

  • Транспорт по умолчанию встроен и использует AsynchronousSocketChannel из Java.
  • Вместо него можно использовать Apache MINA — масштабируемую и высокопроизводительную асинхронную библиотеку ввода-вывода, или
  • также поддерживается асинхронный событийно-ориентированный сетевой фреймворк Netty.

Поддерживаемые стандарты

Документация по эталонной реализации

  • RFC 4251 - Архитектура протокола Secure Shell (SSH)
  • RFC 4252 - Протокол аутентификации Secure Shell (SSH)
  • RFC 4253 - Протокол транспортного уровня Secure Shell (SSH)
  • RFC 4254 - Протокол соединения Secure Shell (SSH)
  • RFC 4256 - Обмен аутентификацией с помощью общих сообщений для протокола Secure Shell (SSH)
  • RFC 4335 - Расширение разрыва сеансового канала Secure Shell (SSH)
  • RFC 4344 - Режимы шифрования транспортного уровня Secure Shell (SSH)
  • RFC 4345 - Улучшенные режимы Arcfour для протокола транспортного уровня Secure Shell (SSH)
  • RFC 4419 - Обмен группами Диффи-Хеллмана для протокола транспортного уровня Secure Shell (SSH)
  • RFC 4716 - Формат файлов открытых ключей Secure Shell (SSH)
  • RFC 5208 - Стандарты криптографии с открытым ключом (PKCS) № 8, версия 1.2
  • RFC 5480 - Информация об открытом ключе субъекта для криптографии на эллиптических кривых
  • RFC 5647 - Режим AES Galois Counter Mode для протокола транспортного уровня Secure Shell
  • RFC 5656 - Интеграция алгоритмов на эллиптических кривых в транспортный уровень Secure Shell
  • RFC 5915 - Структура закрытого ключа на эллиптических кривых
  • RFC 6668 - Проверка целостности данных с помощью SHA-2 для протокола транспортного уровня Secure Shell (SSH)
  • RFC 8160 - Терминальный режим IUTF8 в Secure Shell (SSH)
  • RFC 8268 - Дополнительные группы для обмена ключами Diffie-Hellman (DH) с модульным возведением в степень (MODP) для Secure Shell (SSH)
  • RFC 8308 - Согласование расширений в протоколе Secure Shell (SSH)
    • Примечание: в коде есть хуки для реализации этого RFC, а также предоставляются реализации по умолчанию для клиента и сервера для расширения server-sig-algs.
  • RFC 8332 - Использование ключей RSA с SHA-256 и SHA-512 в протоколе Secure Shell (SSH)
    • Примечание: серверная сторона поддерживает эти подписи по умолчанию. Для клиентской стороны требуется специальная инициализация — см. раздел 3.3, а также упомянутые выше хуки для RFC 8308.
  • RFC 8731 - Метод обмена ключами Secure Shell (SSH) с использованием Curve25519 и Curve448
  • Обновления и рекомендации по методам обмена ключами (KEX) для Secure Shell
  • Поддержка OpenSSH для ключей безопасности U2F/FIDO
    • Примечание: серверная сторона поддерживает эти ключи по умолчанию. Клиентская сторона требует специальной инициализации.
  • Система аутентификации OpenSSH на основе сертификатов открытых ключей для использования в SSH
  • Прыжки через SSH-прокси
  • SFTP версий 3-6 + расширения
    • supported - DRAFT 05 - раздел 4.4
    • supported2 - DRAFT 13 - раздел 5.4
    • versions - DRAFT 09 - раздел 4.6
    • vendor-id - DRAFT 09 - раздел 4.4
    • acl-supported - DRAFT 11 - раздел 5.4
    • newline - DRAFT 09 - раздел 4.3
    • md5-hash, md5-hash-handle - DRAFT 09 - раздел 9.1.1
    • check-file-handle, check-file-name - DRAFT 09 - раздел 9.1.2
    • copy-file, copy-data - DRAFT 00 - разделы 6, 7
    • space-available - DRAFT 09 - раздел 9.2
    • filename-charset, filename-translation-control - DRAFT 13 - раздел 6 - только клиентская сторона
    • Несколько расширений SFTP от OpenSSH
  • Бесконечная ловушка - см. раздел HOWTO(s).

Реализованная/доступная поддержка

Методы аутентификации

  • hostbased, publickey, аутентификация OpenSSH на основе открытых ключей хоста, keyboard-interactive, password

Шифры

  • aes128cbc, aes128ctr, aes192cbc, aes192ctr, aes256cbc, aes256ctr, arcfour128, arcfour256, blowfish-cbc, [email protected], [email protected], [email protected], 3des-cbc

Хеши

  • md5, sha1, sha224, sha256, sha384, sha512

MAC-алгоритмы

  • hmacmd5, hmacmd596, hmacsha1, hmacsha196, hmacsha256, hmacsha512, [email protected] , [email protected], [email protected]

Обмен ключами

  • diffie-hellman-group1-sha1, diffie-hellman-group-exchange-sha256, diffie-hellman-group14-sha1, diffie-hellman-group14-sha256 , diffie-hellman-group15-sha512, diffie-hellman-group16-sha512, diffie-hellman-group17-sha512, diffie-hellman-group18-sha512 , ecdh-sha2-nistp256, ecdh-sha2-nistp384, ecdh-sha2-nistp521, curve25519-sha256, [email protected], curve448-sha512
    • На версиях Java до Java 11 для curve25519-sha256, [email protected] или curve448-sha512 требуется Bouncy Castle.

Сжатие

  • none, zlib, [email protected]
Скачать инструмент