Skip to content
KitploitKITPLOIT
FerramentasExploitsBlog
Log in
Enviar
FerramentasExploitsBlog
Enviar

Ferramentas de Hacking, PenTest e Cibersegurança para o seu Arsenal de Segurança!

Kitploit é um diretório de ferramentas de hacking, cibersegurança e pentesting. Descubra as últimas atualizações de projetos para encontrar vulnerabilidades, analisar sistemas, automatizar testes e fortalecer sua segurança.

··Feeds·Contato·Privacidade·© 2026 Kitploit

Diretório de Ferramentas

Categorias

Ver todas as categorias
Loading categories
apache__mina-sshd_CVE-2023-35887_2-9-2 — Biblioteca SSH cliente/servidor em Java puro que implementa o protocolo SSH-2 com suporte para múltiplas cifras, trocas de chaves, métodos de autenticação, SFTP, SCP e encaminhamento de portas para acesso remoto seguro. | Kitploit
Ferramentas/GitHubGitHub/shoucheng3/apache__mina-sshd_cve-2023-35887_2-9-2
Ferramentas de Criptografia/DescriptografiaAnálise de VulnerabilidadesSegurança de RedeCriptografiaTestes de PenetraçãoUtilitários e FrameworksAutenticaçãoFerramenta de Acesso Remoto

Mais Populares

Ver todos →

Descubra as ferramentas mais usadas pela nossa comunidade.

Explore todas as ferramentas

Navegue pela nossa coleção de ferramentas

Ver todas as ferramentas →
Compartilhar
GitHubshoucheng3/apache__mina-sshd_cve-2023-35887_2-9-2

apache__mina-sshd_CVE-2023-35887_2-9-2

Biblioteca SSH cliente/servidor em Java puro que implementa o protocolo SSH-2 com suporte para múltiplas cifras, trocas de chaves, métodos de autenticação, SFTP, SCP e encaminhamento de portas para acesso remoto seguro.

Ver Repositório
12há 1 anoAinda não revisado

Apache MINA SSHD

Apache MINA SSHD

Apache MINA SSHD é uma biblioteca 100% Java pura para suportar os protocolos SSH tanto no lado do cliente quanto no servidor. Não tem como objetivo ser um substituto para o cliente SSH ou servidor SSH de sistemas operacionais Unix, mas sim fornecer suporte para aplicações baseadas em Java que necessitam de suporte SSH.

A biblioteca pode aproveitar vários back-ends de E/S:

  • O transporte padrão é integrado e usa AsynchronousSocketChannels do Java.
  • Apache MINA, uma biblioteca de E/S assíncrona escalável e de alto desempenho, pode ser usada em vez disso, ou
  • o Netty, um framework de rede assíncrono orientado a eventos, também é suportado.

Padrões suportados

Documentação de implementação de referência

  • RFC 4251 - The Secure Shell (SSH) Protocol Architecture
  • RFC 4252 - The Secure Shell (SSH) Authentication Protocol
  • RFC 4253 - The Secure Shell (SSH) Transport Layer Protocol
  • RFC 4254 - The Secure Shell (SSH) Connection Protocol
  • RFC 4256 - Generic Message Exchange Authentication for the Secure Shell Protocol (SSH)
  • RFC 4335 - The Secure Shell (SSH) Session Channel Break Extension
  • RFC 4344 - The Secure Shell (SSH) Transport Layer Encryption Modes
  • RFC 4345 - Improved Arcfour Modes for the Secure Shell (SSH) Transport Layer Protocol
  • RFC 4419 - Diffie-Hellman Group Exchange for the Secure Shell (SSH) Transport Layer Protocol
  • RFC 4716 - The Secure Shell (SSH) Public Key File Format
  • RFC 5208 - Public-Key Cryptography Standards (PKCS) #8 - version 1.2
  • RFC 5480 - Elliptic Curve Cryptography Subject Public Key Information
  • RFC 5647 - AES Galois Counter Mode for the Secure Shell Transport Layer Protocol
  • RFC 5656 - Elliptic Curve Algorithm Integration in the Secure Shell Transport Layer
  • RFC 5915 - Elliptic Curve Private Key Structure
  • RFC 6668 - SHA-2 Data Integrity Verification for the Secure Shell (SSH) Transport Layer Protocol
  • RFC 8160 - IUTF8 Terminal Mode in Secure Shell (SSH)
  • RFC 8268 - More Modular Exponentiation (MODP) Diffie-Hellman (DH) Key Exchange (KEX) Groups for Secure Shell (SSH)
  • RFC 8308 - Extension Negotiation in the Secure Shell (SSH) Protocol
    • Nota: - o código contém hooks para implementar a RFC e também fornece implementação padrão de cliente e servidor para as extensões server-sig-algs.
  • RFC 8332 - Use of RSA Keys with SHA-256 and SHA-512 in the Secure Shell (SSH) Protocol
    • Nota: - o lado do servidor suporta essas assinaturas por padrão. O lado do cliente requer uma inicialização específica - veja seção 3.3 e também os hooks mencionados acima para RFC 8308.
  • RFC 8731 - Secure Shell (SSH) Key Exchange Method Using Curve25519 and Curve448
  • Key Exchange (KEX) Method Updates and Recommendations for Secure Shell
  • OpenSSH support for U2F/FIDO security keys
    • Nota: o lado do servidor suporta essas chaves por padrão. O lado do cliente requer uma inicialização específica
  • OpenSSH public-key certificate authentication system for use by SSH
  • SSH proxy jumps
  • SFTP versão 3-6 + extensões
    • supported - DRAFT 05 - seção 4.4
    • supported2 - DRAFT 13 seção 5.4
    • versions - DRAFT 09 Seção 4.6
    • vendor-id - DRAFT 09 - seção 4.4
    • acl-supported - DRAFT 11 - seção 5.4
    • newline - DRAFT 09 Seção 4.3
    • md5-hash, md5-hash-handle - DRAFT 09 - seção 9.1.1
    • check-file-handle, check-file-name - DRAFT 09 - seção 9.1.2
    • copy-file, copy-data - DRAFT 00 - seções 6, 7
    • space-available - DRAFT 09 - seção 9.2
    • filename-charset, filename-translation-control - DRAFT 13 - seção 6 - apenas lado do cliente
    • Várias extensões SFTP do OpenSSH
  • Endless tarpit - veja seção HOWTO(s).

Suporte implementado/disponível

Métodos de autenticação

  • hostbased, publickey, OpenSSH host-based public-key, keyboard-interactive, password

Cifras

  • aes128cbc, aes128ctr, aes192cbc, aes192ctr, aes256cbc, aes256ctr, arcfour128, arcfour256, blowfish-cbc, [email protected], [email protected], [email protected], 3des-cbc

Digests

  • md5, sha1, sha224, sha256, sha384, sha512

Macs

  • hmacmd5, hmacmd596, hmacsha1, hmacsha196, hmacsha256, hmacsha512, [email protected] , [email protected], [email protected]

Troca de chaves

  • diffie-hellman-group1-sha1, diffie-hellman-group-exchange-sha256, diffie-hellman-group14-sha1, diffie-hellman-group14-sha256 , diffie-hellman-group15-sha512, diffie-hellman-group16-sha512, diffie-hellman-group17-sha512, diffie-hellman-group18-sha512 , ecdh-sha2-nistp256, ecdh-sha2-nistp384, ecdh-sha2-nistp521, curve25519-sha256, [email protected], curve448-sha512
    • Em versões do Java anteriores ao Java 11, Bouncy Castle é necessário para curve25519-sha256, [email protected] ou curve448-sha512.

Compressões

  • none, zlib, [email protected]

Assinaturas/Chaves

Baixar ferramenta