Skip to content
KitploitKITPLOIT
ツールエクスプロイトブログ
Log in
提出
ツールエクスプロイトブログ
提出

ハッキング、侵入テスト、サイバーセキュリティツールをあなたのセキュリティアーセナルに!

Kitploitはハッキング、サイバーセキュリティ、ペネトレーションテストのツールディレクトリです。最新のプロジェクトアップデートを見つけて、脆弱性の発見、システム分析、テストの自動化、セキュリティの強化を行いましょう。

フィードお問い合わせプライバシー© 2026 Kitploit

ツールディレクトリ

カテゴリ

すべてのカテゴリを見る
Loading categories
Titanis — Windowsプロトコルライブラリ。SMBおよびRPCの実装などを含む。 | Kitploit
ツール/GitHubGitHub/trustedsec/titanis
特権昇格エクスプロイト横移動情報収集ネットワークセキュリティ暗号化ペネトレーションテストユーティリティとフレームワーク認証レッドチーミング
GitHubtrustedsec/titanis

Titanis

82386381ヶ月前Kitploit レビュー済み

人気

すべて見る →

コミュニティで最も使われているツールを見つけましょう。

すべてのツールを探索

ツールコレクションを閲覧

すべてのツールを見る →
共有

Windowsプロトコルライブラリ。SMBおよびRPCの実装などを含む。

リポジトリを見る

ドキュメントサイトのユーザーガイドを参照してください

はじめに

Titanisは、Windows環境と対話するための、C#で書かれたプロトコル実装とコマンドラインユーティリティのライブラリです。.NET 8を使用しており、クロスプラットフォーム(WindowsおよびLinux)です。実装されているプロトコルの一部:

  • SMB2 (MS-SMB2)
    • SMB 2.xおよび3.x(3.1.1まで)
    • 署名や暗号化などのメッセージセキュリティ機能
    • ファイルシステム制御コード(MS-FSCC)のサポートを含む
    • DFSリンク (MS-DFSC)
  • MSRPC (MS-RPCE)
    • エンドポイントマッパー
    • DCOM (MS-DCOM)
    • ディレクトリレプリケーション (MS-DRSR)
      • Windows Server 2008およびWindows Server 2025でテスト済み
      • MS-ZIPとXpressの両方の圧縮をサポート
      • 個々のオブジェクトまたはパーティション全体のレプリケーションをサポート
    • EFS (MS-EFSR)
    • LSA (MS-LSAD および MS-LSAT)
    • リモートレジストリ (MS-RRP)
      • バックアップセマンティクスのサポートを含む
      • SAMダンプ機能を含む
    • セキュリティアカウントマネージャー (MS-SAMR)
    • サービスコントロールマネージャー (MS-SCMR)
    • サーバーサービス (MS-SRVS)
    • WMI (MS-WMI および MS-WMIO)
    • ディレクトリレプリケーション (MS-DRSR)
    • EventLog Remoting Protocol Version 6.0 (MS-EVEN6)
    • Task Scheduler Service Remoting Protocol (MS-TSCH)
    • Remote Authorization API Protocol (MS-RAA)
    • Firewall and Advanced Security Protocol (MS-FASP)
  • LDAP (RFC 4511 および MS-ADTS の一部)
  • セキュリティ
    • NTLM (MS-NLMP)
    • Kerberos (RFC4120 および MS-KILE)
      • レルム間参照
      • PKINIT (MS-PKCA および RFC 4556)
      • S4U (MS-SFU)
        • S4U2self
        • S4U2proxy
      • 暗号化プロファイル
        • DES CBC MD5 (RFC3961) (ASのみ)
        • RC4-HMAC (RFC4757)
        • AES 128/256 (RFC3962)
        • .kirbiおよびccacheファイルのサポート
        • keytabファイルのサポート
      • パスワードの変更 / 設定 (RFC3244)
      • FAST / Armoringおよび複合ID
    • SP-NEGO (MS-SPNG)
  • 統合SOCKS 5サポート(-Socks5パラメータ) (RFC1928)

最近の変更については、変更履歴を参照してください

サポートされている認証シナリオの概要については、認証を参照してください - パラメータで認証を制御する方法について説明しています

このツールセットは、運用環境に統合するためのコールバックとログ機能を実装しています。

コマンドラインツールとそれらで実行できるタスクの一覧については、ツールインデックスを確認してください

対象読者

  • セキュリティ研究者 - さまざまな種類のリクエストに対してWindowsがどのように反応するかを研究する
  • ペネトレーションテスター - アクションを実行し、緩和策が有効で適切に機能しているかをテストする
  • システム管理者 - 管理タスクを実行する

はじめに

ビルド手順

ユーザーの方は、コマンドラインユーティリティの一覧とその使用方法についてユーザーガイドを参照してください。

開発者の方は、コードベースを拡張する方法について開発者ガイドを参照してください。

プロジェクト構成

  • doc/ - プロジェクトドキュメント
  • src/ - プロトコル実装のソースコード
  • test/ - 単体テスト
  • tools/ - スタンドアロンコマンドラインツール
  • samples/ - ライブラリの使用方法を示すサンプルコード

Titanis.sln内では、プロジェクトは以下の機能領域にグループ化されています:

  • Base - 他のコンポーネントで使用されるユーティリティ
  • Crypto - 暗号アルゴリズムの実装
  • Formats - ASN.1など、さまざまな形式の読み書きの実装
  • Protocols - ネットワークプロトコルの実装
  • Security - NTLMやKerberosなど、セキュリティプロトコルの実装
  • Test - 単体テスト
  • Tools - スタンドアロンコマンドラインツール
  • _Build - ビルドプロセスに関連するファイル

いくつかのプロジェクトには、開発中に参照された仕様を参照するReferences.txtという名前のファイルが含まれています。ソースコードには、通常は関連するセクション番号とともに、これらの仕様への参照が含まれています。

ツールをダウンロード