Skip to content
KitploitKITPLOIT
ツールエクスプロイトブログ
Log in
提出
ツールエクスプロイトブログ
提出

ハッキング、侵入テスト、サイバーセキュリティツールをあなたのセキュリティアーセナルに!

Kitploitはハッキング、サイバーセキュリティ、ペネトレーションテストのツールディレクトリです。最新のプロジェクトアップデートを見つけて、脆弱性の発見、システム分析、テストの自動化、セキュリティの強化を行いましょう。

··フィード·お問い合わせ·プライバシー·© 2026 Kitploit

ツールディレクトリ

カテゴリ

すべてのカテゴリを見る
Loading categories
apache__mina-sshd_CVE-2023-35887_2-9-2 — SSH-2プロトコルを実装した純JavaのSSHクライアント/サーバーライブラリ。複数の暗号、鍵交換、認証方式、SFTP、SCP、ポートフォワーディングをサポートし、安全なリモートアクセスを実現。 | Kitploit
ツール/GitHubGitHub/shoucheng3/apache__mina-sshd_cve-2023-35887_2-9-2
暗号化/復号化ツール脆弱性分析ネットワークセキュリティ暗号化ペネトレーションテストユーティリティとフレームワーク認証リモートアクセスツール

人気

すべて見る →

コミュニティで最も使われているツールを見つけましょう。

すべてのツールを探索

ツールコレクションを閲覧

すべてのツールを見る →
共有
GitHub
shoucheng3/apache__mina-sshd_cve-2023-35887_2-9-2

apache__mina-sshd_CVE-2023-35887_2-9-2

SSH-2プロトコルを実装した純JavaのSSHクライアント/サーバーライブラリ。複数の暗号、鍵交換、認証方式、SFTP、SCP、ポートフォワーディングをサポートし、安全なリモートアクセスを実現。

リポジトリを見る
121年前未レビュー

Apache MINA SSHD

Apache MINA SSHD

Apache MINA SSHD は、クライアント側とサーバー側の両方で SSH プロトコルをサポートする 100% 純粋な Java ライブラリです。これは、 Unix オペレーティングシステムの SSH クライアントや SSH サーバーの置き換えを目的とするものではなく、SSH サポートを必要とする Java ベースのアプリケーションにサポートを提供します。

このライブラリは、複数の I/O バックエンドを利用できます。

  • デフォルトのトランスポートは組み込みで、Java の AsynchronousSocketChannel を使用します。
  • Apache MINA は、スケーラブルで高性能な非同期 I/O ライブラリであり、代わりに使用できます。または
  • Netty 非同期イベント駆動型ネットワークフレームワークもサポートされています。

サポートされている標準規格

リファレンス実装ドキュメント

  • RFC 4251 - Secure Shell (SSH) プロトコルアーキテクチャ
  • RFC 4252 - Secure Shell (SSH) 認証プロトコル
  • RFC 4253 - Secure Shell (SSH) トランスポート層プロトコル
  • RFC 4254 - Secure Shell (SSH) 接続プロトコル
  • RFC 4256 - Secure Shell プロトコル (SSH) のための汎用メッセージ交換認証
  • RFC 4335 - Secure Shell (SSH) セッションチャネル休止拡張
  • RFC 4344 - Secure Shell (SSH) トランスポート層暗号化モード
  • RFC 4345 - Secure Shell (SSH) トランスポート層プロトコルのための改良 Arcfour モード
  • RFC 4419 - Secure Shell (SSH) トランスポート層プロトコルのための Diffie-Hellman グループ交換
  • RFC 4716 - Secure Shell (SSH) 公開鍵ファイル形式
  • RFC 5208 - 公開鍵暗号標準 (PKCS) #8 - バージョン 1.2
  • RFC 5480 - 楕円曲線暗号サブジェクト公開鍵情報
  • RFC 5647 - Secure Shell トランスポート層プロトコルのための AES Galois Counter Mode
  • RFC 5656 - Secure Shell トランスポート層における楕円曲線アルゴリズム統合
  • RFC 5915 - 楕円曲線秘密鍵構造
  • RFC 6668 - Secure Shell (SSH) トランスポート層プロトコルのための SHA-2 データ整合性検証
  • RFC 8160 - Secure Shell (SSH) における IUTF8 ターミナルモード
  • RFC 8268 - Secure Shell (SSH) のための追加の Modular Exponentiation (MODP) Diffie-Hellman (DH) 鍵交換 (KEX) グループ
  • RFC 8308 - Secure Shell (SSH) プロトコルにおける拡張ネゴシエーション
    • 注: - コードには RFC を実装するための フック が含まれており、 server-sig-algs 拡張のデフォルトのクライアント実装とサーバー実装も提供します。
  • RFC 8332 - Secure Shell (SSH) プロトコルにおける SHA-256 および SHA-512 を使用した RSA 鍵の使用
    • 注: - サーバー側はデフォルトでこれらの署名をサポートしています。クライアント側は特定の 初期化が必要です - セクション 3.3 および 上記の RFC 8308 用フックを参照してください。
  • RFC 8731 - Curve25519 および Curve448 を使用した Secure Shell (SSH) 鍵交換方式
  • Secure Shell のための鍵交換 (KEX) 方式の更新と推奨事項
  • U2F/FIDO セキュリティキーの OpenSSH サポート
    • 注: サーバー側はデフォルトでこれらの鍵をサポートしています。クライアント側は特定の初期化が必要です
  • SSH で使用する OpenSSH 公開鍵証明書認証システム
  • SSH プロキシジャンプ
  • SFTP バージョン 3-6 + 拡張機能
    • supported - DRAFT 05 - セクション 4.4
    • supported2 - DRAFT 13 - セクション 5.4
    • versions - DRAFT 09 - セクション 4.6
    • vendor-id - DRAFT 09 - セクション 4.4
    • acl-supported - DRAFT 11 - セクション 5.4
    • newline - DRAFT 09 - セクション 4.3
    • md5-hash、md5-hash-handle - DRAFT 09 - セクション 9.1.1
    • check-file-handle、check-file-name - DRAFT 09 - セクション 9.1.2
    • copy-file、copy-data - DRAFT 00 - セクション 6、7
    • space-available - DRAFT 09 - セクション 9.2
    • filename-charset、filename-translation-control - DRAFT 13 - セクション 6 - クライアント側のみ
    • いくつかの OpenSSH SFTP 拡張
  • Endless tarpit - HOWTO(s) セクションを参照してください。

実装済み/利用可能なサポート

認証方式

  • hostbased, publickey, OpenSSH host-based public-key, keyboard-interactive, password

暗号

  • aes128cbc, aes128ctr, aes192cbc, aes192ctr, aes256cbc, aes256ctr, arcfour128, arcfour256, blowfish-cbc, [email protected], [email protected], [email protected], 3des-cbc

ダイジェスト

  • md5, sha1, sha224, sha256, sha384, sha512

MAC

  • hmacmd5, hmacmd596, hmacsha1, hmacsha196, hmacsha256, hmacsha512, [email protected] , [email protected], [email protected]

鍵交換

  • diffie-hellman-group1-sha1, diffie-hellman-group-exchange-sha256, diffie-hellman-group14-sha1, diffie-hellman-group14-sha256 , diffie-hellman-group15-sha512, diffie-hellman-group16-sha512, diffie-hellman-group17-sha512, diffie-hellman-group18-sha512 , ecdh-sha2-nistp256, ecdh-sha2-nistp384, ecdh-sha2-nistp521, curve25519-sha256, [email protected], curve448-sha512
    • Java 11 より前の Java バージョンでは、curve25519-sha256、[email protected]、または curve448-sha512 に Bouncy Castle が必要です。

圧縮

  • none, zlib, [email protected]

署名/鍵

  • ssh-dss, ssh-rsa, rsa-sha2-256, rsa-sha2-512, nistp256, nistp384, nistp521 , ssh-ed25519 (requires eddsa optional module), [email protected], [email protected] , [email protected], [email protected], [email protected] , [email protected], [email protected], [email protected]

注: 上記のリストには、コード内でサポートされているすべてのセキュリティ設定が含まれています。ただし、最新の推奨事項に従い、 デフォルトのクライアント/サーバー設定には、現在安全に使用できると見なされているセキュリティ設定のみが含まれています。含めたいユーザーは、 安全でない設定を 明示的に 行う必要があります。次の設定は非推奨となり、デフォルト設定には含まれなくなりました:

ツールをダウンロード