Skip to content
KitploitKITPLOIT
उपकरणएक्सप्लॉइटब्लॉग
Log in
जमा करें
उपकरणएक्सप्लॉइटब्लॉग
जमा करें

हैकिंग, पेनटेस्ट और साइबर सुरक्षा उपकरण आपके सुरक्षा शस्त्रागार के लिए!

Kitploit हैकिंग, साइबर सुरक्षा और पेंटेस्टिंग टूल्स की एक निर्देशिका है। कमजोरियों को खोजने, सिस्टम का विश्लेषण करने, परीक्षण को स्वचालित करने और अपनी सुरक्षा को मजबूत करने के लिए नवीनतम प्रोजेक्ट अपडेट खोजें।

फ़ीडसंपर्कगोपनीयता© 2026 Kitploit

टूल निर्देशिका

श्रेणियाँ

सभी श्रेणियाँ देखें
Loading categories
Titanis — Windows प्रोटोकॉल लाइब्रेरी, जिसमें SMB और RPC कार्यान्वयन शामिल हैं, अन्य के साथ। | Kitploit
उपकरण/GitHubGitHub/trustedsec/titanis
विशेषाधिकार वृद्धिशोषणपार्श्व आंदोलनजानकारी एकत्र करनानेटवर्क सुरक्षाक्रिप्टोग्राफीपेनिट्रेशन टेस्टिंगउपयोगिताएँ और फ्रेमवर्कप्रमाणीकरणरेड टीमिंग
GitHubtrustedsec/titanis
823863829 दिन पहलेKitploit द्वारा समीक्षित

सबसे लोकप्रिय

सभी देखें →

हमारे समुदाय द्वारा सबसे अधिक उपयोग किए जाने वाले उपकरण खोजें।

सभी उपकरण खोजें

हमारे उपकरणों का संग्रह ब्राउज़ करें

सभी उपकरण देखें →
साझा करें

Titanis

Windows प्रोटोकॉल लाइब्रेरी, जिसमें SMB और RPC कार्यान्वयन शामिल हैं, अन्य के साथ।

रिपॉजिटरी देखें

दस्तावेज़ीकरण साइट पर उपयोगकर्ता गाइड देखें

परिचय

Titanis, Windows वातावरण के साथ इंटरैक्ट करने के लिए C# में लिखी गई प्रोटोकॉल कार्यान्वयन और कमांड लाइन उपयोगिताओं की एक लाइब्रेरी है। यह .NET 8 का उपयोग करती है और क्रॉस-प्लेटफ़ॉर्म (Windows और Linux) है। कुछ कार्यान्वित प्रोटोकॉल:

  • SMB2 (MS-SMB2)
    • SMB 2.x और 3.x, 3.1.1 तक
    • संदेश सुरक्षा सुविधाएँ जैसे साइनिंग और एन्क्रिप्शन
    • फ़ाइलसिस्टम नियंत्रण कोड के लिए समर्थन शामिल है (MS-FSCC)
    • DFS लिंक (MS-DFSC)
  • MSRPC (MS-RPCE)
    • एंडपॉइंट मैपर
    • DCOM (MS-DCOM)
    • डायरेक्टरी रेप्लिकेशन (MS-DRSR)
      • Windows Server 2008 और Windows Server 2025 के साथ परीक्षण किया गया
      • MS-ZIP और Xpress दोनों कम्प्रेशन का समर्थन करता है
      • व्यक्तिगत ऑब्जेक्ट या संपूर्ण पार्टीशन के रेप्लिकेशन का समर्थन करता है
    • EFS (MS-EFSR)
    • LSA (MS-LSAD और MS-LSAT)
    • रिमोट रजिस्ट्री (MS-RRP)
      • बैकअप सेमांटिक्स के लिए समर्थन शामिल है
      • SAM डंप कार्यक्षमता शामिल है
    • सिक्योरिटी अकाउंट्स मैनेजर (MS-SAMR)
    • सर्विस कंट्रोल मैनेजर (MS-SCMR)
    • सर्वर सेवा (MS-SRVS)
    • WMI (MS-WMI और MS-WMIO)
    • डायरेक्टरी रेप्लिकेशन (MS-DRSR)
    • EventLog रिमोटिंग प्रोटोकॉल संस्करण 6.0 (MS-EVEN6)
    • टास्क शेड्यूलर सर्विस रिमोटिंग प्रोटोकॉल (MS-TSCH)
    • रिमोट ऑथराइज़ेशन API प्रोटोकॉल (MS-RAA)
    • फ़ायरवॉल और एडवांस्ड सिक्योरिटी प्रोटोकॉल (MS-FASP)
  • LDAP (RFC 4511 और MS-ADTS के कुछ भाग)
  • सुरक्षा
    • NTLM (MS-NLMP)
    • Kerberos (RFC4120 और MS-KILE)
      • इंटर-रियल्म रेफ़रल
      • PKINIT (MS-PKCA और RFC 4556)
      • S4U (MS-SFU)
        • S4U2self
        • S4U2proxy
      • एन्क्रिप्शन प्रोफ़ाइल
        • DES CBC MD5 (RFC3961) (केवल AS)
        • RC4-HMAC (RFC4757)
        • AES 128/256 (RFC3962)
        • .kirbi और ccache फ़ाइलों के लिए समर्थन
        • keytab फ़ाइलों के लिए समर्थन
      • पासवर्ड बदलें / सेट करें (RFC3244)
      • FAST / आर्मरिंग और कंपाउंड आइडेंटिटी
    • SP-NEGO (MS-SPNG)
  • एकीकृत SOCKS 5 समर्थन (-Socks5 पैरामीटर) (RFC1928)

हाल के परिवर्तनों के लिए, चेंज लॉग देखें

समर्थित प्रमाणीकरण परिदृश्यों के अवलोकन के लिए, प्रमाणीकरण देखें - बताता है कि पैरामीटर के साथ प्रमाणीकरण को कैसे नियंत्रित करें

यह टूलसेट आपके परिचालन वातावरण में एकीकृत होने के लिए कॉलबैक और लॉगिंग सुविधाएँ लागू करता है।

कमांड लाइन टूल्स की सूची और उनके साथ की जा सकने वाली कार्यों के लिए, टूल इंडेक्स देखें

लक्षित दर्शक

  • सुरक्षा शोधकर्ता - शोध करें कि Windows विभिन्न प्रकार के अनुरोधों पर कैसे प्रतिक्रिया देता है
  • पेंटेस्टर - कार्रवाई करें और परीक्षण करें कि शमन उपाय सक्षम हैं और ठीक से काम कर रहे हैं
  • सिस्टम प्रशासक - प्रशासनिक कार्य करें

शुरुआत करना

बिल्ड निर्देश

यदि आप उपयोगकर्ता हैं, तो कमांड लाइन उपयोगिताओं की सूची और उनका उपयोग करने के तरीके के लिए उपयोगकर्ता गाइड देखें।

यदि आप डेवलपर हैं, तो कोड बेस को बेहतर बनाने की जानकारी के लिए डेवलपर गाइड देखें।

प्रोजेक्ट संगठन

  • doc/ - प्रोजेक्ट दस्तावेज़ीकरण
  • src/ - प्रोटोकॉल कार्यान्वयन के लिए स्रोत कोड
  • test/ - यूनिट टेस्ट
  • tools/ - स्टैंडअलोन कमांड लाइन टूल्स
  • samples/ - नमूना कोड जो दर्शाता है कि लाइब्रेरीज़ का उपयोग कैसे करें

Titanis.sln के भीतर, प्रोजेक्ट्स को निम्नलिखित कार्यात्मक क्षेत्रों में समूहीकृत किया गया है:

  • Base - अन्य घटकों द्वारा उपयोग की जाने वाली उपयोगिताएँ
  • Crypto - क्रिप्टोग्राफिक एल्गोरिदम का कार्यान्वयन
  • Formats - विभिन्न प्रारूपों, जैसे ASN.1, को पढ़ने और लिखने के लिए कार्यान्वयन
  • Protocols - नेटवर्क प्रोटोकॉल कार्यान्वयन
  • Security - सुरक्षा प्रोटोकॉल कार्यान्वयन, जैसे NTLM और Kerberos
  • Test - यूनिट टेस्ट
  • Tools - स्टैंडअलोन कमांड लाइन टूल्स
  • _Build - बिल्ड प्रक्रिया से संबंधित फ़ाइलें।

कई प्रोजेक्ट्स में References.txt नाम की एक फ़ाइल होती है जो विकास के दौरान परामर्श किए गए विनिर्देशों का संदर्भ देती है। स्रोत कोड में इन विनिर्देशों के संदर्भ होते हैं, आमतौर पर प्रासंगिक अनुभाग संख्या के साथ।

टूल डाउनलोड करें