Skip to content
KitploitKITPLOIT
OutilsExploitsBlog
Log in
Soumettre
OutilsExploitsBlog
Soumettre

Outils de Hacking, PenTest et Cybersécurité pour votre Arsenal de Sécurité !

Kitploit est un répertoire d'outils de hacking, de cybersécurité et de pentesting. Découvrez les dernières mises à jour des projets pour trouver des vulnérabilités, analyser des systèmes, automatiser les tests et renforcer votre sécurité.

FluxContactConfidentialité© 2026 Kitploit

Répertoire d'outils

Catégories

Voir toutes les catégories
Loading categories
Titanis — Bibliothèque de protocoles Windows, incluant les implémentations SMB et RPC, entre autres. | Kitploit
Outils/GitHubGitHub/trustedsec/titanis
Escalade de PrivilègesExploitationMouvement LatéralCollecte d'InformationsSécurité RéseauCryptographieTests d'IntrusionUtilitaires et FrameworksAuthentificationRed Teaming
GitHubtrustedsec/titanis
8238637il y a 28 joursVérifié par Kitploit

Populaires

Voir tout →

Découvrez les outils les plus utilisés par notre communauté.

Explorer tous les outils

Parcourez notre collection d'outils

Voir tous les outils →
Partager

Titanis

Bibliothèque de protocoles Windows, incluant les implémentations SMB et RPC, entre autres.

Voir le dépôt

Consulter le guide de l'utilisateur sur le site de documentation

Introduction

Titanis est une bibliothèque d'implémentations de protocoles et d'utilitaires en ligne de commande, écrite en C#, pour interagir avec les environnements Windows. Elle utilise .NET 8 et est multiplateforme (Windows et Linux). Voici quelques-uns des protocoles implémentés :

  • SMB2 (MS-SMB2)
    • SMB 2.x et 3.x jusqu'à 3.1.1
    • Fonctionnalités de sécurité des messages telles que la signature et le chiffrement
    • Inclut la prise en charge des codes de contrôle du système de fichiers (MS-FSCC)
    • Liens DFS (MS-DFSC)
  • MSRPC (MS-RPCE)
    • Mappeur de points de terminaison
    • DCOM (MS-DCOM)
    • Réplication d'annuaire (MS-DRSR)
      • Testé avec Windows Server 2008 et Windows Server 2025
      • Prend en charge les compressions MS-ZIP et Xpress
      • Prend en charge la réplication d'objets individuels ou de partitions entières
    • EFS (MS-EFSR)
    • LSA (MS-LSAD et MS-LSAT)
    • Registre distant (MS-RRP)
      • Inclut la prise en charge des sémantiques de sauvegarde
      • Inclut la fonctionnalité de vidage SAM
    • Gestionnaire de comptes de sécurité (MS-SAMR)
    • Gestionnaire de contrôle des services (MS-SCMR)
    • Service serveur (MS-SRVS)
    • WMI (MS-WMI et MS-WMIO)
    • Réplication d'annuaire (MS-DRSR)
    • EventLog Remoting Protocol Version 6.0 (MS-EVEN6)
    • Task Scheduler Service Remoting Protocol (MS-TSCH)
    • Remote Authorization API Protocol (MS-RAA)
    • Firewall and Advanced Security Protocol (MS-FASP)
  • LDAP (RFC 4511 et certaines parties de MS-ADTS)
  • Sécurité
    • NTLM (MS-NLMP)
    • Kerberos (RFC4120 et MS-KILE)
      • Renvois inter-royaumes
      • PKINIT (MS-PKCA et RFC 4556)
      • S4U (MS-SFU)
        • S4U2self
        • S4U2proxy
      • Profils de chiffrement
        • DES CBC MD5 (RFC3961) (AS uniquement)
        • RC4-HMAC (RFC4757)
        • AES 128/256 (RFC3962)
        • Prise en charge des fichiers .kirbi et ccache
        • Prise en charge des fichiers keytab
      • Changer / définir le mot de passe (RFC3244)
      • FAST / Armoring et identité composée
    • SP-NEGO (MS-SPNG)
  • Prise en charge intégrée de SOCKS 5 (paramètre -Socks5) (RFC1928)

Pour les modifications récentes, voir le journal des modifications

Pour un aperçu des scénarios d'authentification pris en charge, voir Authentification - Décrit comment contrôler l'authentification avec des paramètres

L'ensemble d'outils implémente des fonctionnalités de rappel et de journalisation pour s'intégrer à votre environnement opérationnel.

Pour une liste des outils en ligne de commande et des tâches que vous pouvez effectuer avec eux, consultez l'Index des outils

Public cible

  • Chercheurs en sécurité - Étudier comment Windows réagit à divers types de requêtes
  • Testeurs d'intrusion - Effectuer des actions et tester si les atténuations sont activées et fonctionnent correctement
  • Administrateurs système - Effectuer des tâches administratives

Pour commencer

Instructions de compilation

Si vous êtes un utilisateur, consultez le Guide de l'utilisateur pour une liste des utilitaires en ligne de commande et leur utilisation.

Si vous êtes un développeur, consultez le Guide du développeur pour plus d'informations sur la façon d'améliorer la base de code.

Organisation du projet

  • doc/ - Documentation du projet
  • src/ - Code source des implémentations de protocoles
  • test/ - Tests unitaires
  • tools/ - Outils en ligne de commande autonomes
  • samples/ - Exemples de code démontrant comment utiliser les bibliothèques

Dans Titanis.sln, les projets sont regroupés dans les domaines fonctionnels suivants :

  • Base - Utilitaires utilisés par d'autres composants
  • Crypto - Implémentation d'algorithmes cryptographiques
  • Formats - Implémentations pour la lecture et l'écriture de divers formats, tels que ASN.1
  • Protocols - Implémentations de protocoles réseau
  • Security - Implémentations de protocoles de sécurité, tels que NTLM et Kerberos
  • Test - Tests unitaires
  • Tools - Outils en ligne de commande autonomes
  • _Build - Fichiers relatifs au processus de compilation.

Plusieurs des projets contiennent un fichier nommé References.txt qui référence les spécifications consultées lors du développement. Le code source contient des références à ces spécifications, généralement accompagnées du numéro de section pertinent.

Télécharger l’outil