
Chronicle parser for CORELIGHT and related information.
This document describes how you can collect Corelight Sensor logs by configuring the Corelight Sensor and a Chronicle forwarder. This document also lists the supported log types and supported Corelight versions.
For more information, see Data ingestion to Chronicle.
The following deployment architecture diagram illustrates how a Corelight Sensor is set up to send logs to Google Security Operations using two different ingestion architectures. It's important to note that each customer deployment may vary from this representation and could be more complex.
An ingestion label identifies the parser which normalizes raw log data to structured UDM format. The information in this document applies to the parser with the CORELIGHT ingestion label.

The architecture diagram shows the following components:
Corelight Sensor: The system running the Corelight Sensor .
Corelight Sensor exporters: The Corelight Sensor exporter collects log data from the Sensor, and forwards it to Google Security Operations.
Google Security Operations: Google Security Operations retains and analyzes the logs from Corelight Sensor.
Use the Sensor or Fleet Manager web interface to configure the Google SecOps exporter. This configuration uses the API credentials from your Google SecOps instance to establish the secure connection.
Log in to the Fleet Manager or Sensor web interface of Corelight Sensor as an administrator.
Navigate to the exporter configuration area:
In the Create Exporter section, click Google SecOps.




The architecture diagram shows the following components:
Corelight Sensor: The system running the Corelight Sensor .
Corelight Sensor exporter: The Corelight Sensor exporter collects log data from the Sensor, and forwards it to the Google Security Operations forwarder.
Google Security Operations forwarder: The Google Security Operations forwarder is a lightweight software component, deployed in the customer's network, that supports syslog. The Google Security Operations forwarder forwards the logs to Google Security Operations.
Google Security Operations: Google Security Operations retains and analyzes the logs from Corelight Sensor.
To configure the Google Security Operations forwarder, do the following:
Set up a Google Security Operations forwarder. See Install and configure the forwarder on Linux.
Configure the Google Security Operations forwarder to send logs to Google Security Operations.
collectors:
- syslog:
common:
enabled: true
data_type: CORELIGHT
data_hint:
batch_n_seconds: 10
batch_n_bytes: 1048576
tcp_address: <Chronicle forwarder listening IP:Port>
tcp_buffer_size: 524288
udp_address: <Chronicle forwarder listening IP:Port>
connection_timeout_sec: 60

The Corelight parser supports the following log types:
This section explains how the Google Security Operations parser maps Google Security Operations fields to Google Security Operations Unified Data Model (UDM) fields.
The following table lists common fields of the CORELIGHT log and their corresponding UDM fields.
The following table lists the log fields of the asset_classification log type and their corresponding UDM fields.
The following table lists the log fields of the conn, conn_red, conn_long, conn_agg log type and their corresponding UDM fields.
The following table lists the log fields of the dce_rpc log type and their corresponding UDM fields.
The following table lists the log fields of the dns, dns_red, dns_agg log type and their corresponding UDM fields.
The following table lists the log fields of the http, http_red, http2, http_agg log type and their corresponding UDM fields.
The following table lists the log fields of the smtp_links log type and their corresponding UDM fields.
The following table lists the log fields of the irc log type and their corresponding UDM fields.
The following table lists the log fields of the files, files_red, files_agg log type and their corresponding UDM fields.
The following table lists the log fields of the notice log type and their corresponding UDM fields.
The following table lists the log fields of the smb_files log type and their corresponding UDM fields.
The following table lists the log fields of the smb_mapping log type and their corresponding UDM fields.
The following table lists the log fields of the ssl, ssl_red, ssl_agg log type and their corresponding UDM fields.
The following table lists the log fields of the rdp log type and their corresponding UDM fields.
The following table lists the log fields of the sip log type and their corresponding UDM fields.
The following table lists the log fields of the intel log type and their corresponding UDM fields.
The following table lists the log fields of the smtp log type and their corresponding UDM fields.
The following table lists the log fields of the ssh log type and their corresponding UDM fields.
The following table lists the log fields of the suricata_corelight log type and their corresponding UDM fields.
| Log field | UDM mapping | Logic |
|---|
metadata.vendor_name | The metadata.vendor_name UDM field is set to Corelight. | |
_path (string) | metadata.product_event_type | |
_system_name (string) | observer.hostname | |
ts (time) | metadata.event_timestamp | |
uid (string) | about.labels [uid], network.session_id | |
id.orig_h (string - addr) | principal.ip | |
id.orig_p (integer - port) | principal.port | |
id.resp_h (string - addr) | target.ip | |
id.resp_p (integer - port) | target.port | |
_write_ts | metadata.collected_timestamp | |
id.vlan (integer - int) | additional.fields [id_vlan] | |
id.vlan_inner (integer - int) | additional.fields [id_vlan_inner] | |
id.orig_ep_cid (string) | additional.fields [id_orig_ep_cid] | |
id.orig_ep_source (string) | additional.fields [id_orig_ep_source] | |
id.orig_ep_status (string) | additional.fields [id_orig_ep_status] | |
id.orig_ep_uid (string) | additional.fields [id_orig_ep_uid] | |
id.resp_ep_cid (string) | additional.fields [id_resp_ep_cid] | |
id.resp_ep_source (string) | additional.fields [id_resp_ep_source] | |
id.resp_ep_status (string) | additional.fields [id_resp_ep_status] | |
id.resp_ep_uid (string) | additional.fields [id_resp_ep_uid] | |
uids (array[string] - vector of string) | additional.fields [uid] | |
count (integer - int) | additional.fields [count] | |
ts_last | additional.fields [ts_last] |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to STATUS_UPDATE. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
ip (string - addr) | principal.ip | |
mac | principal.mac | |
vendor_mac (string) | about.asset.hardware.manufacturer | |
device_type (string) | about.asset.category | |
os_name (string) | about.platform | |
os_name (string) | about.asset.attribute.labels | |
type_group (string) | about.group.group_display_name | |
type_name (string) | about.resource.resource_subtype | The about.resource.resource_type UDM field is set to DEVICE |
brand (string) | about.user.company_name | |
model (string) | about.asset.hardware.model | |
confidence (integer) | about.security_result.confidence_score | |
os_ver (string) | about.platform_version | |
sources (array[string]) | about.ip_geo_artifact.tags |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to NETWORK_CONNECTION. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
proto (string - enum) | network.ip_protocol | |
service (string) | network.application_protocol | |
duration (number - interval) | network.session_duration | |
orig_bytes (integer - count) | network.sent_bytes | |
resp_bytes (integer - count) | network.received_bytes | |
conn_state (string) | metadata.description | If the conn_state log field value is equal to S0, then the metadata.description UDM field is set to S0: Connection attempt seen, no reply.Else, if the conn_state log field value is equal to S1, then the metadata.description UDM field is set to S1: Connection established, not terminated.Else, if the conn_state log field value is equal to S2, then the metadata.description UDM field is set to S2: Connection established and close attempt by originator seen (but no reply from responder).Else, if the conn_state log field value is equal to S3, then the metadata.description UDM field is set to S3: Connection established and close attempt by responder seen (but no reply from originator).Else, if the conn_state log field value is equal to SF, then the metadata.description UDM field is set to SF: Normal SYN/FIN completion.Else, if the conn_state log field value is equal to REJ, then the metadata.description UDM field is set to REJ: Connection attempt rejected.Else, if the conn_state log field value is equal to RSTO, then the metadata.description UDM field is set to RSTO: Connection established, originator aborted (sent a RST).Else, if the conn_state log field value is equal to RSTOS0, then the metadata.description UDM field is set to RSTOS0: Originator sent a SYN followed by a RST, we never saw a SYN-ACK from the responder.Else, if the conn_state log field value is equal to RSTOSH, then the metadata.description UDM field is set to RSTOSH: Responder sent a SYN ACK followed by a RST, we never saw a SYN from the (purported) originator.Else, if the conn_state log field value is equal to RSTR, then the metadata.description UDM field is set to RSTR: Established, responder aborted.Else, if the conn_state log field value is equal to SH, then the metadata.description UDM field is set to SH: Originator sent a SYN followed by a FIN, we never saw a SYN ACK from the responder (hence the connection was "half" open).Else, if the conn_state log field value is equal to SHR, then the metadata.description UDM field is set to SHR: Responder sent a SYN ACK followed by a FIN, we never saw a SYN from the originator.Else, if the conn_state log field value is equal to OTH, then the metadata.description UDM field is set to OTH: No SYN seen, just midstream traffic (a partial connection that was not later closed). |
local_orig (boolean - bool) | about.labels [local_orig] | |
local_resp (boolean - bool) | about.labels [local_resp] | |
missed_bytes (integer - count) | about.labels [missed_bytes] | |
history (string) | about.labels [history] | |
orig_pkts (integer - count) | network.sent_packets | |
orig_ip_bytes (integer - count) | principal.labels [orig_ip_bytes] | |
resp_pkts (integer - count) | network.received_packets | |
resp_ip_bytes (integer - count) | target.labels [resp_ip_bytes] | |
tunnel_parents (array[string] - set[string]) | intermediary.labels [tunnel_parent] | |
orig_cc (string) | principal.ip_geo_artifact.location.country_or_region | |
resp_cc (string) | target.ip_geo_artifact.location.country_or_region | |
suri_ids (array[string] - set[string]) | security_result.rule_id | |
spcap.url (string) | security_result.url_back_to_product | |
spcap.rule (integer - count) | security_result.rule_labels [spcap_rule] | |
spcap.trigger (string) | security_result.detection_fields [spcap_trigger] | |
app (array[string] - vector of string) | about.application | |
corelight_shunted (boolean - bool) | about.labels [corelight_shunted] | |
orig_shunted_pkts (integer - count) | principal.labels [orig_shunted_pkts] | |
orig_shunted_bytes (integer - count) | principal.labels [orig_shunted_bytes] | |
resp_shunted_pkts (integer - count) | target.labels [resp_shunted_pkts] | |
resp_shunted_bytes (integer - count) | target.labels [resp_shunted_bytes] | |
orig_l2_addr (string) | principal.mac | |
resp_l2_addr (string) | target.mac | |
id_orig_h_n.src (string) | principal.labels [id_orig_h_n_src] | |
id_orig_h_n.vals (array[string] - set[string]) | principal.labels [id_orig_h_n_val] | |
id_resp_h_n.src (string) | target.labels [id_resp_h_n_src] | |
id_resp_h_n.vals (array[string] - set[string]) | target.labels [id_resp_h_n_val] | |
vlan (integer - int) | intermediary.labels [vlan] | |
inner_vlan (integer - int) | intermediary.labels [inner_vlan] | |
community_id (string) | network.community_id | |
security_result.severity | The security_result.severity UDM field is set to INFORMATIONAL. | |
service (string) | about.labels [service] | |
orig_ep_cid (string) | additional.fields [orig_ep_cid] | |
orig_ep_source (string) | additional.fields [orig_ep_source] | |
orig_ep_status (string) | additional.fields [orig_ep_status] | |
orig_ep_uid (string) | additional.fields [orig_ep_uid] | |
resp_ep_cid (string) | additional.fields [resp_ep_cid] | |
resp_ep_source (string) | additional.fields [resp_ep_source] | |
resp_ep_status (string) | additional.fields [resp_ep_status] | |
resp_ep_uid (string) | additional.fields [resp_ep_uid] | |
id_orig_h_n | principal.ip | |
id_resp_h_n | target.ip | |
netskope_site_ids | additional.fields[netskope_site_ids] | Iterate through log field netskope_site_ids, then netskope_site_id_%{index} log field is mapped to the additional.fields.key UDM field and netskope_site_id log field is mapped to the additional.fields.value UDM field. |
netskope_user_ids | additional.fields[netskope_user_ids] | Iterate through log field netskope_user_ids, then netskope_user_id_%{index} log field is mapped to the additional.fields.key UDM field and netskope_user_id log field is mapped to the additional.fields.value UDM field. |
write_ts | additional.fields[write_ts] | |
spcap.urls (array[string] - vector of string) | security_result.url_back_to_product | Iterate through log field spcap.urls, then spcap.urls log field is mapped to the security_result.url_back_to_product UDM field. |
community_ids (array[string] - vector of string) | network.community_id | Iterate through log field community_ids, thenif index is equal to 0 then, community_id log field is mapped to the network.community_id UDM field. Else, community_id_%{index} log field is mapped to the additional.fields.key UDM field and community_id log field is mapped to the additional.fields.value UDM field. |
capture_metadata.vpc.version | about.resource.attribute.labels[vpc_version] | |
capture_metadata.vpc.vpc_id | about.resource.product_object_id | |
about.resource.resource_type | If capture_metadata.vpc.vpc_id is present, then about.resource.resource_type UDM field is set to VPC_NETWORK. | |
capture_source | about.resource.attribute.labels[capture_source] | |
orig_inst.az | principal.location.name | |
orig_inst.id | principal.resource.product_object_id | |
orig_inst.name | principal.resource.name | |
orig_inst.org_id | principal.resource.attribute.labels[org_id] | |
orig_inst.sg_ids | principal.resource.attribute.labels[sg_id] | |
orig_inst.subnet_id | principal.resource.attribute.labels[subnet_id] | |
orig_inst.vpc_id | principal.resource.attribute.labels[vpc_id] | |
principal.resource.resource_type | If orig_inst.vpc_id is present, then principal.resource.resource_type UDM field is set to VPC_NETWORK. | |
orig_inst.profile | principal.resource.attribute.labels[profile] | |
resp_inst.az | target.location.name | |
resp_inst.id | target.resource.product_object_id | |
resp_inst.name | target.resource.name | |
resp_inst.org_id | target.resource.attribute.labels[org_id] | |
resp_inst.sg_ids | target.resource.attribute.labels[sg_id] | |
resp_inst.subnet_id | target.resource.attribute.labels[subnet_id] | |
resp_inst.vpc_id | target.resource.attribute.labels[vpc_id] | |
target.resource.resource_type | If resp_inst.vpc_id is present, then target.resource.resource_type UDM field is set to VPC_NETWORK. | |
resp_inst.profile | target.resource.attribute.labels[profile] | |
local_orig and local_resp | additional.fields[direction] | If the local_orig log field value is equal to true and local_resp log field value is equal to true, then the additional.fields[direction] UDM field is set to internal.Else, if the local_orig log field value is equal to true and local_resp log field value is equal to false, then the additional.fields[direction] UDM field is set to outbound.Else, if the local_orig log field value is equal to false and local_resp log field value is equal to false, then the additional.fields[direction] UDM field is set to external.Else, if the local_orig log field value is equal to false and local_resp log field value is equal to true, then the additional.fields[direction] UDM field is set to inbound. |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to NETWORK_CONNECTION. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
rtt (number - interval) | network.session_duration | |
named_pipe (string) | intermediary.resource.name | |
intermediary.resource.resource_type | If the named_pipe log field value is not empty, then the intermediary.resource.resource_type UDM field is set to PIPE. | |
endpoint (string) | target.labels [endpoint] | |
operation (string) | target.labels [operation] | |
network.application_protocol | The network.application_protocol UDM field is set to DCERPC. | |
security_result.severity | The security_result.severity UDM field is set to INFORMATIONAL. | |
operation, endpoint, named_pipe (string) | metadata.description | The metadata.description UDM field is set with operation, endpoint, named_pipe log fields as "operation operation on endpoint using named pipe named_pipe". |
network.ip_protocol | The network.ip_protocol UDM field is set to TCP. |
| Log field | UDM mapping | Logic |
|---|
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
metadata.event_type | The metadata.event_type UDM field is set to NETWORK_DNS. | |
network.application_protocol | The network.application_protocol UDM field is set to DNS. | |
proto (string - enum) | network.ip_protocol | |
trans_id (integer - count) | network.dns.id | |
rtt (number - interval) | network.session_duration | |
query (string) | network.dns.questions.name | |
qclass (integer - count) | network.dns.questions.class | |
qclass_name (string) | about.labels [qclass_name] | |
qtype (integer - count) | network.dns.questions.type | |
qtype_name (string) | about.labels [qtype_name] | |
rcode (integer - count) | network.dns.response_code | |
rcode (integer - count) | network.dns.response | If the rcode log field value is not empty, then the network.dns.response UDM field is set to true. |
rcode_name (string) | about.labels [rcode_name] | |
AA (boolean - bool) | network.dns.authoritative | |
TC (boolean - bool) | network.dns.truncated | |
RD (boolean - bool) | network.dns.recursion_desired | |
RA (boolean - bool) | network.dns.recursion_available | |
Z (integer - count) | about.labels [Z] | |
answers (array[string] - vector of string) | network.dns.answers.name | |
TTLs (array[number] - vector of interval) | network.dns.answers.ttl | |
rejected (boolean - bool) | about.labels [rejected] | |
is_trusted_domain (string) | about.labels [is_trusted_domain] | |
icann_host_subdomain (string) | about.labels [icann_host_subdomain] | |
icann_domain (string) | network.dns_domain | |
icann_tld (string) | about.labels [icann_tld] | |
num (integer - count) | security_result.detection_fields [num] |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to NETWORK_HTTP. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
trans_depth (integer - count) | about.labels [trans_depth] | |
method (string) | network.http.method | |
host (string) | target.hostname | |
uri (string) | target.url | |
referrer (string) | network.http.referral_url | |
version (string) | network.application_protocol_version | |
user_agent (string) | network.http.user_agent | |
origin (string) | principal.hostname | |
request_body_len (integer - count) | network.sent_bytes | |
response_body_len (integer - count) | network.received_bytes | |
status_code (integer - count) | network.http.response_code | |
status_msg (string) | about.labels [status_msg] | |
info_code (integer - count) | about.labels [info_code] | |
info_msg (string) | about.labels [info_msg] | |
tags (array[string] - set[enum]) | about.labels [tags] | |
username (string) | principal.user.user_display_name | |
password (string) | extensions.auth.auth_details | |
proxied (array[string] - set[string]) | intermediary.hostname | |
orig_fuids (array[string] - vector of string) | about.labels [orig_fuid] | |
orig_filenames (array[string] - vector of string) | src.file.names | The orig_filenames log field is mapped to src.file.names UDM field when index value in orig_filenames is equal to 0. For every other index value, orig_filenames log field is mapped to the about.file.names.
|
orig_mime_types (array[string] - vector of string) | src.file.mime_type | The orig_mime_types log field is mapped to src.file.mime_type UDM field when index value in orig_mime_types is equal to 0. For every other index value, orig_mime_types log field is mapped to the about.file.mime_type.
|
resp_fuids (array[string] - vector of string) | about.labels [resp_fuid] | |
resp_filenames (array[string] - vector of string) | target.file.names | The resp_filenames log field is mapped to target.file.names UDM field when index value in resp_filenames is equal to 0. For every other index value, resp_filenames log field is mapped to the about.file.names.
|
resp_mime_types (array[string] - vector of string) | target.file.mime_type | The resp_mime_types log field is mapped to target.file.mime_type UDM field when index value in resp_mime_types is equal to 0. For every other index value, resp_mime_types log field is mapped to the about.file.mime_type.
|
post_body (string) | about.labels [post_body] | |
stream_id (integer - count) | about.labels [stream_id] | |
encoding (string) | about.labels [encoding] | |
push (boolean - bool) | about.labels [push] | |
versions (array[float] - vector of float) | network.application_protocol_version | Iterate through log field versions, thenif index is equal to 0 then, version log field is mapped to the network.application_protocol_version UDM field. Else, version_%{index} log field is mapped to the additional.fields.key UDM field and version log field is mapped to the additional.fields.value UDM field. |
user_agents (array[string] - vector of string) | network.http.user_agent | Iterate through log field user_agents, thenif index is equal to 0 then, user_agent log field is mapped to the network.http.user_agent UDM field. Else, user_agent_%{index} log field is mapped to the additional.fields.key UDM field and user_agent log field is mapped to the additional.fields.value UDM field. |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to NETWORK_SMTP. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
network.application_protocol | The network.application_protocol UDM field is set to SMTP. | |
fuid (string) | about.labels [fuid] | |
link (string) | about.url | |
domain (string) | about.domain.name |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to NETWORK_UNCATEGORIZED. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
nick (string) | principal.user.user_display_name | |
user (string) | principal.user.userid | If the user log field value is less than or equal to 255, then the user log field is mapped to the principal.user.userid UDM field.Else, the user log field is mapped to the about.labels UDM field. |
command, value, addl | principal.process.command_line | |
dcc_file_name (string) | src.file.names | |
dcc_file_size (integer - count) | src.file.size | |
dcc_mime_type (string) | src.file.mime_type | |
fuid (string) | about.labels [fuid] |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to NETWORK_UNCATEGORIZED. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
fuid (string) | about.labels [fuid] | |
tx_hosts (array[string] - set[addr]) | principal.ip | |
rx_hosts (array[string] - set[addr]) | target.ip | |
conn_uids (array[string] - set[string]) | about.labels [conn_uid] | |
source (string) | about.labels [source] | |
depth (integer - count) | about.labels [depth] | |
analyzers (array[string] - set[string]) | about.labels [analyzer] | |
mime_type (string) | about.file.mime_type | |
filename (string) | about.file.names | |
duration (number - interval) | about.labels [duration] | |
local_orig (boolean - bool) | about.labels [local_orig] | |
is_orig (boolean - bool) | about.labels [is_orig] | |
seen_bytes (integer - count) | about.file.size | |
total_bytes (integer - count) | about.labels [total_bytes] | |
missing_bytes (integer - count) | about.labels [missing_bytes] | |
overflow_bytes (integer - count) | about.labels [overflow_bytes] | |
timedout (boolean - bool) | about.labels [timedout] | |
parent_fuid (string) | about.labels [parent_fuid] | |
md5 (string) | about.file.md5 | |
sha1 (string) | about.file.sha1 | |
sha256 (string) | about.file.sha256 | |
md5 (string) | network.tls.client.certificate.md5 | If the source log field value is equal to ssl and the mime_type log field value is equal to application/x-x509-user-cert and the _path log field value is equal to files, then the network.tls.client.certificate.md5 UDM field is set to md5. |
sha1 (string) | network.tls.client.certificate.sha1 | If the source log field value is equal to ssl and the mime_type log field value is equal to application/x-x509-user-cert and the _path log field value is equal to files, then the network.tls.client.certificate.sha1 UDM field is set to sha1. |
sha256 (string) | network.tls.client.certificate.sha256 | If the source log field value is equal to ssl and the mime_type log field value is equal to application/x-x509-user-cert and the _path log field value is equal to files, then the network.tls.client.certificate.sha256 UDM field is set to sha256. |
md5 (string) | network.tls.server.certificate.md5 | If the source log field value is equal to ssl and the mime_type log field value is equal to application/x-x509-ca-cert and the _path log field value is equal to files, then the network.tls.server.certificate.md5 UDM field is set to md5. |
sha1 (string) | network.tls.server.certificate.sha1 | If the source log field value is equal to ssl and the mime_type log field value is equal to application/x-x509-ca-cert and the _path log field value is equal to files, then the network.tls.server.certificate.sha1 UDM field is set to sha1. |
sha256 (string) | network.tls.server.certificate.sha256 | If the source log field value is equal to ssl and the mime_type log field value is equal to application/x-x509-ca-cert and the _path log field value is equal to files, then the network.tls.server.certificate.sha256 UDM field is set to sha256. |
extracted (array[string] - set[string]) | about.file.names | |
extracted_cutoff (boolean - bool) | about.labels [extracted_cutoff] | |
extracted_size (integer - count) | about.labels [extracted_size] | |
num (integer - count) | about.labels [num] | |
vlan (integer - int) | additional.fields [vlan] | |
vlan_inner (integer - int) | additional.fields [vlan_inner] | |
mime_types (array[string] - vector of string) | target.file.mime_type | Iterate through log field mime_type, thenif index is equal to 0 then, mime_type log field is mapped to the target.file.mime_type UDM field. Else, mime_type_%{index} log field is mapped to the additional.fields.key UDM field and mime_type log field is mapped to the additional.fields.value UDM field. |
timedouts (array[boolean] - vector of bool) | additional.fields[timedouts] | Iterate through log field timedouts, then timedout_%{index} log field is mapped to the additional.fields.key UDM field and timedouts log field is mapped to the additional.fields.value UDM field. |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to NETWORK_UNCATEGORIZED. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
fuid (string) | about.labels [fuid] | |
file_mime_type (string) | target.file.mime_type | |
file_desc (string) | about.labels [file_desc] | |
proto (string - enum) | network.ip_protocol | |
note (string - enum) | security_result.description | |
msg (string) | metadata.description | |
sub (string) | about.labels [sub] | |
src (string - addr) | principal.ip | |
dst (string - addr) | target.ip | |
p (integer - port) | about.port | |
n (integer - count) | about.labels [n] | |
peer_descr (string) | about.labels [peer_descr] | |
security_result.action | The security_result.action UDM field is set to ALLOW. | |
actions (array[string] - set[enum]) | security_result.action_details | |
suppress_for (number - interval) | about.labels [suppress_for] | |
remote_location.country_code (string) | about.location.country_or_region | The about.location.country_or_region UDM field is set with remote_location.country_code, remote_location.region log fields as "remote_location.country_code: remote_location.region". |
remote_location.region (string) | about.location.country_or_region | The about.location.country_or_region UDM field is set with remote_location.country_code, remote_location.region log fields as "remote_location.country_code: remote_location.region". |
remote_location.city (string) | about.location.city | |
remote_location.latitude (number - double) | about.location.region_coordinates.latitude | |
remote_location.longitude (number - double) | about.location.region_coordinates.longitude | |
security_result.severity | If the severity.level log field value contain one of the following values
security_result.severity UDM field is set to HIGH. Else, If severity.level log field value is equal to 2 then, the security_result.severity UDM field is set to CRITICAL. Else, If severity.level log field value is equal to 3 then, the security_result.severity UDM field is set to ERROR. Else, If severity.level log field value contain one of the following values
security_result.severity UDM field is set to INFORMATIONAL. Else, If severity.level log field value is equal to 7 then, the security_result.severity UDM field is set to LOW. Else The security_result.severity UDM field is set to UNKNOWN_SEVERITY. | |
severity.name | security_result.severity_details | |
severity.level | security_result.detection_fields [severity_level] | |
resp_vulnerable_host.criticality (string) | target.asset.vulnerabilities.severity | If the resp_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Critical" or the then, the "target.asset.vulnerabilities.severity" UDM field is set to CRITICAL. Else, If resp_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)High" or the then, the "target.asset.vulnerabilities.severity" UDM field is set to HIGH. Else, If resp_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Low" or the then, the "target.asset.vulnerabilities.severity" UDM field is set to LOW. Else, If resp_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Medium" or the then, the "target.asset.vulnerabilities.severity" UDM field is set to MEDIUM. Else, If resp_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Unknown_Severity" or the resp_vulnerable_host.criticality log field value is equal to "0 " then, the "target.asset.vulnerabilities.severity" UDM field is set to UNKNOWN_SEVERITY. |
resp_vulnerable_host.criticality (string) | target.asset.vulnerabilities.severity_details | |
resp_vulnerable_host.cve (string) | target.asset.vulnerabilities.cve_id | |
resp_vulnerable_host.host_uid (string) | additional.fields [resp_vulnerable_host_uid] | |
resp_vulnerable_host.hostname (string) | target.asset.hostname | |
resp_vulnerable_host.machine_domain (string) | target.asset.network_domain | |
resp_vulnerable_host.os_version (string) | target.asset.platform_software.platform_version | |
resp_vulnerable_host.source (string) | target.asset.vulnerabilities.cve_description | |
orig_vulnerable_host.criticality (string) | principal.asset.vulnerabilities.severity | If the orig_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Critical" or the then, the "principal.asset.vulnerabilities.severity" UDM field is set to CRITICAL. Else, If orig_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)High" or the then, the "principal.asset.vulnerabilities.severity" UDM field is set to HIGH. Else, If orig_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Low" or the then, the "principal.asset.vulnerabilities.severity" UDM field is set to LOW. Else, If orig_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Medium" or the then, the "principal.asset.vulnerabilities.severity" UDM field is set to MEDIUM. Else, If orig_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Unknown_Severity" or the orig_vulnerable_host.criticality log field value is equal to "0 " then, the "principal.asset.vulnerabilities.severity" UDM field is set to UNKNOWN_SEVERITY. |
orig_vulnerable_host.criticality (string) | principal.asset.vulnerabilities.severity_details | |
orig_vulnerable_host.cve (array[string] - vector of string) | principal.asset.vulnerabilities.cve_id | |
orig_vulnerable_host.host_uid (string) | additional.fields [orig_vulnerable_host_uid] | |
orig_vulnerable_host.hostname (string) | principal.asset.hostname | |
orig_vulnerable_host.machine_domain (string) | principal.asset.network_domain | |
orig_vulnerable_host.os_version (string) | principal.asset.platform_software.platform_version | |
orig_vulnerable_host.source (string) | principal.asset.vulnerabilities.cve_description |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | If the action log field value is equal to SMB::FILE_READ, then the metadata.event_type UDM field is set to FILE_READ.Else, if the action log field value is equal to SMB::FILE_WRITE, then the metadata.event_type UDM field is set to FILE_MODIFICATION.Else, if the action log field value is equal to SMB::FILE_OPEN, then the metadata.event_type UDM field is set to FILE_OPEN.Else, if the action log field value is equal to SMB::FILE_CLOSE, then the metadata.event_type UDM field is set to FILE_UNCATEGORIZED.Else, if the action log field value is equal to SMB::FILE_DELETE, then the metadata.event_type UDM field is set to FILE_DELETION.Else, if the action log field value is equal to SMB::FILE_RENAME, then the metadata.event_type UDM field is set to FILE_MOVE.Else, if the action log field value is equal to SMB::FILE_SET_ATTRIBUTE, then the metadata.event_type UDM field is set to FILE_UNCATEGORIZED.Else, the metadata.event_type UDM field is set to FILE_UNCATEGORIZED. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
network.application_protocol | The network.application_protocol UDM field is set to SMB. | |
network.ip_protocol | The network.ip_protocol UDM field is set to TCP. | |
action, name | metadata.description | The metadata.description UDM field is set with action, name log fields as "action: action on: name". |
security_result.severity | The security_result.severity UDM field is set to INFORMATIONAL. | |
security_result.action | The security_result.action UDM field is set to ALLOW. | |
fuid (string) | about.labels [fuid] | |
action (string - enum) | target.labels [action] | |
path (string) | target.file.full_path | |
name (string) | target.file.names | |
size (integer - count) | target.file.size | |
prev_name (string) | src.file.names | |
times.modified (time) | target.file.last_modification_time | |
times.accessed (time) | target.file.last_seen_time | |
times.created (time) | target.file.first_seen_time | |
times.changed (time) | target.labels [times_changed] | |
data_offset_req (integer - count) | target.labels [data_offset_req] | |
data_len_req (integer - count) | target.labels [data_len_req] | |
data_len_rsp (integer - count) | target.labels [data_len_rsp] |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to NETWORK_CONNECTION. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
network.application_protocol | The network.application_protocol UDM field is set to SMB. | |
network.ip_protocol | The network.ip_protocol UDM field is set to TCP. | |
security_result.severity | The security_result.severity UDM field is set to INFORMATIONAL. | |
security_result.action | The security_result.action UDM field is set to ALLOW. | |
path (string) | target.resource.attribute.labels [path] | |
service (string) | target.application | |
native_file_system (string) | target.resource.attribute.labels [native_file_system] | |
share_type (string) | target.resource.resource_type | If the share_type log field value is equal to DISK, then the target.resource.resource_type UDM field is set to STORAGE_OBJECT.Else, if the share_type log field value is equal to PIPE, then the target.resource.resource_type UDM field is set to PIPE.Else, the target.resource.resource_type UDM field is set to UNSPECIFIED. |
share_type (string) | target.resource.resource_subtype |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to NETWORK_CONNECTION. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
network.application_protocol | The network.application_protocol UDM field is set to HTTPS. | |
network.ip_protocol | The network.ip_protocol UDM field is set to TCP. | |
security_result.severity | The security_result.severity UDM field is set to INFORMATIONAL. | |
security_result.action | The security_result.action UDM field is set to ALLOW. | |
version (string) | network.tls.version | |
cipher (string) | network.tls.cipher | |
curve (string) | network.tls.curve | |
server_name (string) | network.tls.client.server_name | |
resumed (boolean - bool) | network.tls.resumed | |
last_alert (string) | security_result.description | |
next_protocol (string) | network.tls.next_protocol | |
established (boolean - bool) | network.tls.established | |
ssl_history (string) | about.labels [ssl_history] | |
cert_chain_fps (array[string] - vector of string) | target.labels [cert_chain_fps] | |
client_cert_chain_fps (array[string] - vector of string) | principal.labels [client_cert_chain_fps] | |
sni_matches_cert (boolean - bool) | about.labels [sni_matches_cert] | |
validation_status (string) | security_result.description | |
ja3 (string) | network.tls.client.ja3 | |
ja3s (string) | network.tls.server.ja3s |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to NETWORK_CONNECTION. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
cookie (string) | principal.user.userid | |
result (string) | about.labels [result] | |
security_protocol (string) | target.labels [security_protocol] | |
client_channels (array[string] - vector of string) | intermediary.labels [client_channels] | |
keyboard_layout (string) | principal.labels [keyboard_layout] | |
client_build (string) | principal.asset.software.version | |
client_name (string) | principal.hostname | |
client_dig_product_id (string) | principal.asset.product_object_id | |
desktop_width (integer - count) | principal.labels [desktop_width] | |
desktop_height (integer - count) | principal.labels [desktop_height] | |
requested_color_depth (string) | principal.labels [requested_color_depth] | |
cert_type (string) | about.labels [cert_type] | |
cert_count (integer - count) | about.labels [cert_count] | |
cert_permanent (boolean - bool) | about.labels [cert_permanent ] | |
encryption_level (string) | about.labels [encryption_level] | |
encryption_method (string) | about.labels [encryption_method] | |
auth_success (boolean - bool) | security_result.action | If the auth_success log field value is equal to true then, the security_result.action UDM field is set to ALLOW. Else, the security_result.action UDM field is set to FAIL. |
channels_joined (integer - int) | intermediary.labels [channels_joined] | |
inferences (array[string] - set[string]) | about.labels [inferences] | |
rdpeudp_uid (string) | about.labels [rdpeudp_uid] | |
network.ip_protocol | The network.ip_protocol UDM field is set to TCP. | |
rdfp_string (string) | principal.labels [rdfp_string] | |
rdfp_hash (string) | principal.labels [rdfp_hash] | |
result, security_protocol | security_result.description | The security_result.description UDM field is set with result, security_protocol log fields as "result connection with security protocol security_protocol". |
security_result.severity | The security_result.severity UDM field is set to INFORMATIONAL. |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to NETWORK_UNCATEGORIZED. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
network.application_protocol | The network.application_protocol UDM field is set to SIP. | |
trans_depth (integer - count) | about.labels [trans_depth] | |
method (string) | about.labels [method] | |
uri (string) | target.url | |
date (string) | about.labels [date] | |
request_from (string) | principal.labels [request_from] | |
request_to (string) | target.labels [request_to] | |
response_from | principal.labels [response_from] | |
response_to (string) | target.labels [response_to] | |
reply_to (string) | about.labels [reply_to] | |
call_id (string) | about.labels[call_id] | |
seq (string) | about.labels [seq] | |
subject (string) | about.labels [subject] | |
request_path (array[string] - vector of string) | about.labels [request_path] | |
response_path (array[string] - vector of string) | about.labels [response_path] | |
user_agent (string) | about.labels [user_agent] | |
status_code (integer - count) | about.labels [status_code] | |
status_msg (string) | security_result.description | |
warning (string) | security_result.summary | |
request_body_len (integer - count) | network.sent_bytes | |
response_body_len (integer - count) | network.received_bytes | |
content_type (string) | about.labels [content_type] |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to SCAN_NETWORK. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
seen.indicator_type (string - enum) | entity.metadata.entity_type | If the indicator.type log field value is equal to Intel::ADDR, then the metadata.entity_type UDM field is set to IP_ADDRESS.Else, if the indicator.type log field value is equal to Intel::SUBNET or Intel::SOFTWARE or Intel::CERT_HASH or Intel::PUBKEY_HASH, then the metadata.entity_type UDM field is set to RESOURCE.Else, if the indicator.type log field value is equal to Intel::URL, then the metadata.entity_type UDM field is set to URL.Else, if the indicator.type log field value is equal to the Intel::EMAIL or Intel::USER_NAME, then the metadata.entity_type UDM field is set to USER.Else, if the indicator.type log field value is equal to Intel::DOMAIN, then the metadata.entity_type UDM field is set to DOMAIN_NAME.Else, if the indicator.type log field value is equal to the Intel::FILE_HASH or Intel::FILE_NAME, then the metadata.entity_type UDM field is set to FILE.Else, the metadata.entity_type UDM field is set to RESOURCE. |
seen.indicator (string) | entity.ip | If the indicator.type log field value is equal to Intel::ADDR, then the seen.indicator log field is mapped to the entity.ip UDM field. |
seen.indicator (string) | entity.url | If the indicator.type log field value is equal to Intel::URL, then the seen.indicator log field is mapped to the entity.url UDM field. |
seen.indicator (string) | entity.domain.name | If the indicator.type log field value is equal to Intel::DOMAIN, then the seen.indicator log field is mapped to the entity.domain.name UDM field. |
seen.indicator (string) | entity.user.email_address | If the indicator.type log field value is equal to Intel::USER_NAME or Intel::EMAIL, then the seen.indicator log field is mapped to the entity.user.email_address UDM field. |
seen.indicator (string) | entity.file.names | If the indicator.type log field value is equal to Intel::FILE_HASH or Intel::FILE_NAME, then the seen.indicator log field is mapped to the entity.file.full_path UDM field. |
seen.indicator (string) | entity.resource.name | If the metadata.entity_type log field value is equal to RESOURCE, then the seen.indicator log field is mapped to the entity.resource.name UDM field. |
entity.resource.resource_type | If the indicator.type log field value is equal to Intel::SUBNET, then the entity.resource.resource_name UDM field is set to VPC_NETWORK. | |
seen.indicator_type (string - enum) | entity.resource.resource_sub_type | If the metadata.entity_type log field value is equal to RESOURCE, then the seen.indicator_type log field is mapped to the entity.resource.resource_sub_type UDM field. |
seen.where (string - enum) | entity.metadata.source_labels [seen_where] | |
matched (array[string] - set[enum]) | entity.labels [matched] | |
sources (array[string] - set[string]) | entity.metadata.source_labels [source] | |
fuid (string) | about.labels [fuid] | |
file_mime_type (string) | entity.file.mime_type | |
file_desc (string) | metadata.threat.detection_fields [file_desc] | |
desc (array[string] - set[string]) | ioc.description | The desc log field is mapped to ioc.description UDM field when index value in desc is equal to 0.
For every other index value, entity.labels.key UDM field is set to desc and desc log field is mapped to the entity.labels.value. |
url (array[string] - set[string]) | metadata.threat.url_back_to_product | |
confidence (array[number] - set[double]) | ioc.confidence_score | The confidence log field is mapped to ioc.confidence_score UDM field when index value in confidence is equal to 0.
For every other index value, entity.labels.key UDM field is set to confidence and confidence log field is mapped to the entity.labels.value. |
firstseen (array[string] - set[string]) | ioc.active_timerange.start | The firstseen log field is mapped to ioc.active_timerange.start UDM field when index value in firstseen is equal to 0.
For every other index value, entity.labels.key UDM field is set to firstseen and firstseen log field is mapped to the entity.labels.value. |
lastseen (array[string] - set[string]) | ioc.active_timerange.end | The lastseen log field is mapped to ioc.active_timerange.end UDM field when index value in lastseen is equal to 0.
For every other index value, entity.labels.key UDM field is set to lastseen and lastseen log field is mapped to the entity.labels.value. |
associated (array[string] - set[string]) | entity.labels [associated] | |
category (array[string] - set[string]) | ioc.categorization | The category log field is mapped to ioc.categorization UDM field when index value in category is equal to 0.
For every other index value, entity.labels.key UDM field is set to category and category log field is mapped to the entity.labels.value. |
campaigns (array[string] - set[string]) | entity.labels [campaign] | |
reports (array[string] - set[string]) | entity.labels [report] | |
seen.indicator (string) | about.labels [indicator] | |
seen.indicator_type (string - enum) | about.labels [indicator_type] | |
seen.where (string - enum) | about.labels [where] | |
sources (array[string] - set[string]) | about.labels [sources] | |
confidence (array[number] - set[double]) | about.labels [confidence] | |
category (array[string] - set[string]) | about.labels [category] | |
threat_score (array[number] - set[double]) | entity.security_result.detection_fields[threat_score] | |
verdict (array[string] - set[string]) | entity.security_result.verdict_info.verdict_response | Iterate through verdict,If the verdict log field value matches the regular expression pattern "(?i)Malicious" or the then, the "entity.security_result.verdict_info.verdict_response" UDM field is set to MALICIOUS. Else, If verdict log field value matches the regular expression pattern "(?i)Benign" or the then, the "entity.security_result.verdict_info.verdict_response" UDM field is set to BENIGN. Else The "entity.security_result.verdict_info.verdict_response" UDM field is set to VERDICT_RESPONSE_UNSPECIFIED. |
verdict_source (array[string] - set[string]) | entity.security_result.verdict_info.source_provider | Iterate through verdict_source,verdict_source log field is mapped to the entity.security_result.VerdictInfo.source_provider UDM field. |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to NETWORK_SMTP. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
network.application_protocol | The network.application_protocol UDM field is set to SMTP. | |
trans_depth (integer - count) | about.labels [trans_depth] | |
helo (string) | network.smtp.helo | |
mailfrom (string) | network.smtp.mail_from | |
rcptto (array[string] - set[string]) | network.smtp.rcpt_to | |
date (string) | about.labels [date] | |
from (string) | network.email.from | |
to (array[string] - set[string]) | network.email.to | |
cc (array[string] - set[string]) | network.email.cc | |
reply_to (string) | network.email.reply_to | |
msg_id (string) | network.email.mail_id | |
in_reply_to (string) | about.labels [in_reply_to] | |
subject (string) | network.email.subject | |
x_originating_ip (string - addr) | principal.ip | |
first_received (string) | about.labels [first_received] | |
second_received (string) | about.labels [second_received] | |
last_reply (string) | network.smtp.server_response | |
path (array[string] - vector of addr) | network.smtp.message_path | Iterate through log field path, thenif the index value is equal to 0 then, path log field is mapped to the network.smtp.message_path UDM field. Else, path log field is mapped to the intermediary.ip UDM field. |
user_agent (string) | principal.application | |
tls (boolean - bool) | network.smtp.is_tls | |
fuids (array[string] - vector of string) | about.labels [fuid] | |
is_webmail (boolean - bool) | network.smtp.is_webmail | |
urls (array[string] - set[string]) | about.url | |
domains (array[string] - set[string]) | about.domain.name |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to NETWORK_UNCATEGORIZED. | |
metadata.product_name | The metadata.product_name UDM field is set to Zeek. | |
network.application_protocol | The network.application_protocol UDM field is set to SSH. | |
version (integer - count) | network.application_protocol_version | The network.application_protocol_version UDM field is set with version log field as "SSH version". |
auth_success (boolean - bool) | security_result.action_details | |
auth_success (boolean - bool) | security_result.action | If the auth_success log field value is not equal to true, then the security_result.action UDM field is set to ALLOW.Else, the security_result.action UDM field is set to BLOCK. |
auth_attempts (integer - count) | extensions.auth.auth_details | The extensions.auth.auth_details UDM field is set with auth_attempts log field as "auth_attempts: auth_attempts". |
direction (string - enum) | network.direction | If the direction log field value is equal to INBOUND, then the network.direction UDM field is set to INBOUND.Else, if the direction log field value is equal to OUTBOUND, then the network.direction UDM field is set to OUTBOUND. |
client (string) | principal.asset.software.version | |
server (string) | target.asset.software.version | |
cipher_alg (string) | network.tls.cipher | |
mac_alg (string) | security_result.detection_fields [mac_alg] | |
compression_alg (string) | security_result.detection_fields [compression_alg] | |
kex_alg (string) | security_result.detection_fields [kex_alg] | |
host_key_alg (string) | network.tls.server.certificate.version | |
host_key (string) | network.tls.server.certificate.sha256 | |
remote_location.country_code (string) | target.location.country_or_region | |
remote_location.region (string) | target.location.country_or_region | |
remote_location.city (string) | target.location.city | |
remote_location.latitude (number - double) | target.location.region_coordinates.latitude | |
remote_location.longitude (number - double) | target.location.region_coordinates.longitude | |
hasshVersion (string) | about.labels [hassh_version] | |
hassh (string) | principal.labels [hassh] | |
hasshServer (string) | target.labels [hassh_server] | |
cshka (string) | about.labels [cshka] | |
hasshAlgorithms (string) | about.labels [hassh_algorithms] | |
sshka (string) | about.labels [sshka] | |
hasshServerAlgorithms (string) | about.labels [hassh_server_algorithms] | |
inferences (array[string] - set[string]) | security_result.summary, security_result.description, security_result.detection_fields[inferences] | If the inferences log field value is equal to ABP, then the security_result.summary UDM field is set to Client Authentication Bypass and the security_result.description UDM field is set to A client wasn't adhering to expectations of SSH either through server exploit or by the client and server switching to a protocol other than SSH after encryption begins.If the inferences log field value is equal to AFR, then the security_result.summary UDM field is set to SSH Agent Forwarding Requested and the security_result.description UDM field is set to Agent Forwarding is requested by the Client.If the inferences log field value is equal to APWA, then the security_result.summary UDM field is set to Automated Password Authentication and the security_result.description UDM field is set to The client authenticated with an automated password tool (like sshpass).If the inferences log field value is equal to AUTO, then the security_result.summary UDM field is set to Automated Interaction and the security_result.description UDM field is set to The client is a script automated utility and not driven by a user.If the inferences log field value is equal to BAN, then the security_result.summary UDM field is set to Server Banner and the security_result.description UDM field is set to The server sent the client a pre-authentication banner, likely for legal reasons.If the inferences log field value is equal to BF, then the security_result.summary UDM field is set to Client Brute Force Guessing and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to .
If the log field value is equal to , then the UDM field is set to and the UDM field is set to . |
| Log field | UDM mapping | Logic |
|---|
metadata.event_type | The metadata.event_type UDM field is set to SCAN_NETWORK. | |
metadata.product_name | The metadata.product_name UDM field is set to Suricata. | |
id.vlan (integer - count) | intermediary.labels [id_vlan] | |
id.vlan_inner (integer - count) | intermediary.labels [id_vlan_inner] | |
icmp_type (integer - count) | about.labels [icmp_type] | |
icmp_code (integer - count) | about.labels [icmp_code] | |
suri_id (string) | metadata.product_log_id | |
service (string) | network.application_protocol | |
flow_id (integer - count) | about.labels[flow_id] | |
tx_id (integer - count) | about.labels [tx_id] | |
pcap_cnt (integer - count) | about.labels [pcap_cnt] | |
alert.action (string) | security_result.action_details | |
alert.gid (integer - count) | security_result.detection_fields [alert_gid] | |
alert.signature_id (integer - count) | security_result.rule_id | |
alert.rev (integer - count) | security_result.rule_version | |
alert.signature (string) | security_result.summary | |
alert.signature (string) | security_result.rule_name | |
alert.category (string) | security_result.category_details | |
alert.severity (integer - count) | security_result.severity_details | |
alert.metadata (array[string] - vector of string) | security_result.rule_labels[alert_metadata] | |
community_id (string) | network.community_id | |
payload (string) | about.labels [payload] | |
payload (string) | about.labels [payload_decoded] | |
packet (string) | about.labels [packet] | |
packet (string) | about.labels [packet_decoded] | |
metadata (array[string] - vector of string) | security_result.rule_labels[metadata] | |
orig_cve (string) | extensions.vulns.vulnerabilities.cve_id | |
resp_cve (string) | extensions.vulns.vulnerabilities.cve_id | |
signature_severity | security_result.severity | If alert.rule log field value matches the grok pattern signature_severity (?Critical|Major|Minor|Informational) then If the signature_severity extracted field value is equal to Critical then, the security_result.severity UDM field is set to CRITICAL and signature_severity extracted field is mapped to the security_result.severity_details UDM field. Else, If signature_severity extracted field value is equal to Major then, the security_result.severity UDM field is set to MEDIUM and signature_severity extracted field is mapped to the security_result.severity_details UDM field. Else, If signature_severity extracted field value is equal to Minor then, the security_result.severity UDM field is set to LOW and signature_severity extracted field is mapped to the security_result.severity_details UDM field. Else, If signature_severity extracted field value is equal to Informational then, the security_result.severity UDM field is set to INFORMATIONAL and signature_severity extracted field is mapped to the security_result.severity_details UDM field. |
orig_vulnerable_host.cve (array[string] - vector of string) | principal.asset.vulnerabilities.cve_id | |
orig_vulnerable_host.hostname(string) | principal.asset.hostname | |
orig_vulnerable_host.host_uid(string) | about.labels [orig_vulnerable_host_uid] | |
orig_vulnerable_host.machine_domain(string) | principal.asset.network_domain | |
orig_vulnerable_host.os_version(string) | principal.asset.platform_software.platform_version | |
orig_vulnerable_host.source(string) | principal.asset.vulnerabilities.cve_description | |
resp_vulnerable_host.cve(string) | target.asset.vulnerabilities.cve_id | |
resp_vulnerable_host.hostname(string) | target.asset.hostname | |
resp_vulnerable_host.host_uid(string) | about.labels [resp_vulnerable_host_uid] | |
resp_vulnerable_host.machine_domain(string) | target.asset.network_domain | |
resp_vulnerable_host.os_version(string) | target.asset.platform_software.platform_version | |
resp_vulnerable_host.source(string) | target.asset.vulnerabilities.cve_description | |
service (string) | about.labels [service] | |
alert.rule (string) | security_result.description | |
alert.references (array[string] - vector of string) | security_result.detection_fields[alert_references] | iterate through alert.references,alert.references log field is mapped to the security_result.detection_fields.alert_references UDM field. |
payload_printable (string) | security_result.detection_fields[payload_printable] | |
references (array[string] - vector of string) | security_result.detection_fields[references] | iterate through references,references log field is mapped to the security_result.detection_fields.references UDM field. |
orig_vulnerable_host.criticality (string) | principal.asset.vulnerabilities.severity | If the orig_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Critical" or the then, the "principal.asset.vulnerabilities.severity" UDM field is set to CRITICAL. Else, If orig_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)High" or the then, the "principal.asset.vulnerabilities.severity" UDM field is set to HIGH. Else, If orig_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Low" or the then, the "principal.asset.vulnerabilities.severity" UDM field is set to LOW. Else, If orig_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Medium" or the then, the "principal.asset.vulnerabilities.severity" UDM field is set to MEDIUM. Else, If orig_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Unknown_Severity" or the then, the "principal.asset.vulnerabilities.severity" UDM field is set to UNKNOWN_SEVERITY. |
orig_vulnerable_host.criticality (string) | principal.asset.vulnerabilities.severity_details | |
resp_vulnerable_host.criticality (string) | target.asset.vulnerabilities.severity | If the resp_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Critical" or the then, the "target.asset.vulnerabilities.severity" UDM field is set to CRITICAL. Else, If resp_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)High" or the then, the "target.asset.vulnerabilities.severity" UDM field is set to HIGH. Else, If resp_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Low" or the then, the "target.asset.vulnerabilities.severity" UDM field is set to LOW. Else, If resp_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Medium" or the then, the "target.asset.vulnerabilities.severity" UDM field is set to MEDIUM. Else, If resp_vulnerable_host.criticality log field value matches the regular expression pattern "(?i)Unknown_Severity" or the then, the "target.asset.vulnerabilities.severity" UDM field is set to UNKNOWN_SEVERITY. |
resp_vulnerable_host.criticality (string) | target.asset.vulnerabilities.severity_details | |
rule_content | security_result.detection_fields[alert_rule_content] | If alert.rule log field value matches the grok pattern %{GREEDYDATA:_}content:\\"%{GREEDYDATA:rule_content}\\" then, the rule_content extracted field is mapped to security_result.detection_fields [alert_rule_content] UDM field. |
rule_classtype | security_result.detection_fields [alert_rule_classtype] | If alert.rule log field value matches the grok pattern %{GREEDYDATA:_}classtype:%{DATA:rule_classtype}; then, the rule_classtype extracted field is mapped to security_result.detection_fields [alert_rule_classtype] UDM field. |
reference_url | security_result.detection_fields[alert_rule_reference_url] |
security_result.descriptionA client made a number of authentication attempts that exceeded some configured, pre-connection thresholdinferencesBFSsecurity_result.summaryClient Brute Force Successsecurity_result.descriptionA client made a number of authentication attempts that exceeded some configured, pre-connection thresholdinferencesCTSsecurity_result.summaryClient Trusted Serversecurity_result.descriptionThe client already has an entry in its known_hosts file for this serverinferencesCUSsecurity_result.summaryClient Untrusted Serversecurity_result.descriptionThe client did not have an entry in its known_hosts file for this serverinferencesIPWAsecurity_result.summaryInteractive Password Authenticationsecurity_result.descriptionThe client interactively typed their password to authenticateinferencesKSsecurity_result.summaryKeystrokessecurity_result.descriptionAn interactive session occurred in which the client set user-driven keystrokes to the serverinferencesLFDsecurity_result.summaryLarge Client File Downloadsecurity_result.descriptionA file transfer occurred in which the server sent a sequence of bytes to the clientinferencesLFUsecurity_result.summaryLarge Client File Uploadsecurity_result.descriptionA file transfer occurred in which the client sent a sequence of bytes to the server. Large file are identified dynamically based on trains of MTU-sized packetsinferencesMFAsecurity_result.summaryMultifactor Authenticationsecurity_result.descriptionThe server required a second form of authentication (a code) after password or public key was accepted, and the client successfully provided itinferencesNAsecurity_result.summaryNone Authenticationsecurity_result.descriptionThe client successfully authenticated using the None methodinferencesNRCsecurity_result.summaryNo Remote Commandsecurity_result.descriptionThe -N flag was used in SSH authenticationinferencesPKAsecurity_result.summaryPublic Key Authenticationsecurity_result.descriptionThe client automatically authenticated using pubkey authenticationinferencesRSIsecurity_result.summaryReverse SSH Initiatedsecurity_result.descriptionThe Reverse session is initiated from the server back to the clientinferencesRSIAsecurity_result.summaryReverse SSH Initiated Automatedsecurity_result.descriptionThe inititation of the Reverse session happened very early in the packet stream, indicating automationinferencesRSKsecurity_result.summaryReverse SSH Keystrokessecurity_result.descriptionKeystrokes are detected within the Reverse tunnelinferencesRSLsecurity_result.summaryReverse SSH Logged Insecurity_result.descriptionThe Reverse Tunnel login has succeededinferencesRSPsecurity_result.summaryReverse SSH Provisionedsecurity_result.descriptionThe client connected with -R flag, which provisions the port to be used for a Reverse Session set up at any future timeinferencesSAsecurity_result.summaryAuthentication Scanningsecurity_result.descriptionThe client scanned authentication method with the server and then disconnectedinferencesSCsecurity_result.summaryCapabilities Scanningsecurity_result.descriptionThe client exchanged capabilities with the server and then disconnectedinferencesSFDsecurity_result.summarySmall Client File Downloadsecurity_result.descriptionA file transfer occurred in which the server sent a sequence of bytes to the clientinferencesSFUsecurity_result.summarySmall Client File Uploadsecurity_result.descriptionA file transfer occurred in which the client sent a sequence of bytes to the serverinferencesSPsecurity_result.summaryOther Scanningsecurity_result.descriptionA client and server didn't exchange encrypted packets but the client wasn't a version or capabilities scannerinferencesSVsecurity_result.summaryVersion Scanningsecurity_result.descriptionA client exchanged version strings with the server and than disconnectedinferencesUAsecurity_result.summaryUnknown Authenticationsecurity_result.descriptionThe authentication method is not determinated or is unknown