Skip to content
KitploitKITPLOIT
أدواتعمليات الاستغلالالمدونة
Log in
إرسال
أدواتعمليات الاستغلالالمدونة
إرسال

أدوات الاختراق واختبار الاختراق والأمن السيبراني لترسانتك الأمنية!

Kitploit هو دليل لأدوات الاختراق والأمن السيبراني واختبار الاختراق. اكتشف آخر تحديثات المشاريع للعثور على الثغرات وتحليل الأنظمة وأتمتة الاختبارات وتعزيز أمنك.

الخلاصاتاتصالالخصوصية© 2026 Kitploit

دليل الأدوات

الفئات

عرض جميع الفئات
Loading categories
Titanis — مكتبة بروتوكولات ويندوز، بما في ذلك تطبيقات SMB وRPC، من بين أمور أخرى. | Kitploit
أدوات/GitHubGitHub/trustedsec/titanis
تصعيد الامتيازاتالاستغلالالحركة الجانبيةجمع المعلوماتأمن الشبكاتالتشفيراختبار الاختراقالأدوات والمكوناتالمصادقةالفريق الأحمر
GitHubtrustedsec/titanis
8238638منذ 29 أيامتمت المراجعة من قبل Kitploit

الأكثر شعبية

عرض الكل →

اكتشف الأدوات الأكثر استخدامًا من قبل مجتمعنا.

استكشف جميع الأدوات

تصفح مجموعتنا من الأدوات

عرض جميع الأدوات →
مشاركة

Titanis

مكتبة بروتوكولات ويندوز، بما في ذلك تطبيقات SMB وRPC، من بين أمور أخرى.

عرض المستودع

عرض دليل المستخدم على موقع التوثيق

مقدمة

Titanis هي مكتبة من تطبيقات البروتوكولات وأدوات سطر الأوامر، مكتوبة بلغة C#، للتفاعل مع بيئات Windows. تستخدم .NET 8 وهي متعددة المنصات (Windows وLinux). بعض البروتوكولات المُنفَّذة:

  • SMB2 (MS-SMB2)
    • SMB 2.x و3.x حتى 3.1.1
    • ميزات أمان الرسائل مثل التوقيع والتشفير
    • يتضمن دعمًا لأكواد التحكم في نظام الملفات (MS-FSCC)
    • روابط DFS (MS-DFSC)
  • MSRPC (MS-RPCE)
    • مُخطِّط نقاط النهاية
    • DCOM (MS-DCOM)
    • تكرار الدليل (MS-DRSR)
      • تم اختباره مع Windows Server 2008 وWindows Server 2025
      • يدعم كلاً من ضغط MS-ZIP وXpress
      • يدعم تكرار الكائنات الفردية أو الأقسام بأكملها
    • EFS (MS-EFSR)
    • LSA (MS-LSAD وMS-LSAT)
    • السجل عن بُعد (MS-RRP)
      • يتضمن دعمًا لدلالات النسخ الاحتياطي
      • يتضمن وظيفة تفريغ SAM
    • مدير حسابات الأمان (MS-SAMR)
    • مدير التحكم في الخدمات (MS-SCMR)
    • خدمة الخادم (MS-SRVS)
    • WMI (MS-WMI وMS-WMIO)
    • تكرار الدليل (MS-DRSR)
    • بروتوكول EventLog Remoting Protocol الإصدار 6.0 (MS-EVEN6)
    • بروتوكول Task Scheduler Service Remoting Protocol (MS-TSCH)
    • بروتوكول Remote Authorization API Protocol (MS-RAA)
    • بروتوكول Firewall and Advanced Security Protocol (MS-FASP)
  • LDAP (RFC 4511 وأجزاء من MS-ADTS)
  • الأمان
    • NTLM (MS-NLMP)
    • Kerberos (RFC4120 وMS-KILE)
      • الإحالات بين النطاقات
      • PKINIT (MS-PKCA وRFC 4556)
      • S4U (MS-SFU)
        • S4U2self
        • S4U2proxy
      • ملفات تعريف التشفير
        • DES CBC MD5 (RFC3961) (AS فقط)
        • RC4-HMAC (RFC4757)
        • AES 128/256 (RFC3962)
        • دعم ملفات .kirbi وccache
        • دعم ملفات keytab
      • تغيير / تعيين كلمة المرور (RFC3244)
      • FAST / Armoring والهوية المركبة
    • SP-NEGO (MS-SPNG)
  • دعم SOCKS 5 المدمج (معامل -Socks5) (RFC1928)

للاطلاع على التغييرات الأخيرة، راجع سجل التغييرات

للحصول على نظرة عامة حول سيناريوهات المصادقة المدعومة، راجع المصادقة - يصف كيفية التحكم في المصادقة باستخدام المعاملات

تتضمن مجموعة الأدوات ميزات الاستدعاء والتسجيل للتكامل مع بيئتك التشغيلية.

للحصول على قائمة بأدوات سطر الأوامر والمهام التي يمكنك تنفيذها بها، راجع فهرس الأدوات

الجمهور المستهدف

  • باحثو الأمان - البحث في كيفية تفاعل Windows مع أنواع مختلفة من الطلبات
  • مختبرو الاختراق - تنفيذ الإجراءات واختبار ما إذا كانت إجراءات التخفيف مفعّلة وتعمل بشكل صحيح
  • مسؤولو النظام - تنفيذ المهام الإدارية

البدء

تعليمات البناء

إذا كنت مستخدمًا، راجع دليل المستخدم للحصول على قائمة بأدوات سطر الأوامر وكيفية استخدامها.

إذا كنت مطورًا، راجع دليل المطور للحصول على معلومات حول كيفية تحسين قاعدة الكود.

تنظيم المشروع

  • doc/ - توثيق المشروع
  • src/ - الكود المصدري لتطبيقات البروتوكولات
  • test/ - اختبارات الوحدة
  • tools/ - أدوات سطر الأوامر المستقلة
  • samples/ - كود نموذجي يوضح كيفية استخدام المكتبات

داخل Titanis.sln، يتم تجميع المشاريع في المجالات الوظيفية التالية:

  • Base - الأدوات المساعدة المستخدمة من قبل المكونات الأخرى
  • Crypto - تطبيق الخوارزميات التشفيرية
  • Formats - تطبيقات لقراءة وكتابة تنسيقات مختلفة، مثل ASN.1
  • Protocols - تطبيقات بروتوكولات الشبكة
  • Security - تطبيقات بروتوكولات الأمان، مثل NTLM وKerberos
  • Test - اختبارات الوحدة
  • Tools - أدوات سطر الأوامر المستقلة
  • _Build - الملفات ذات الصلة بعملية البناء.

تحتوي العديد من المشاريع على ملف باسم References.txt يشير إلى المواصفات التي تم الرجوع إليها أثناء التطوير. يحتوي الكود المصدري على مراجع لهذه المواصفات، عادةً مع رقم القسم ذي الصلة.

تنزيل الأداة